Does this look normal?

sudo apt upgrade
Reading package lists... Done
Building dependency tree
Reading state information... Done
Calculating upgrade... Done
The following packages will be upgraded:
curl gir1.2-javascriptcoregtk-4.0 gir1.2-webkit2-4.0 intel-microcode
libcurl3-gnutls libcurl4 libjavascriptcoregtk-4.0-18 libnss3
libwebkit2gtk-4.0-37
9 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Need to get 31,8 MB of archives.
After this operation, 6 279 kB of additional disk space will be used.
Do you want to continue? [Y/n] y
Get:1 Index of /ubuntu focal-updates/main amd64 curl amd64 7.68.0-1ubuntu2.16 [161 kB]
Get:2 Index of /ubuntu focal-updates/main amd64 libcurl4 amd64 7.68.0-1ubuntu2.16 [235 kB]
Get:3 Index of /ubuntu focal-updates/main amd64 libwebkit2gtk-4.0-37 amd64 2.38.5-0ubuntu0.20.04.1 [17,5 MB]
Get:4 Index of /ubuntu focal-updates/main amd64 libjavascriptcoregtk-4.0-18 amd64 2.38.5-0ubuntu0.20.04.1 [6 445 kB]
Get:5 Index of /ubuntu focal-updates/main amd64 gir1.2-webkit2-4.0 amd64 2.38.5-0ubuntu0.20.04.1 [80,5 kB]
Get:6 Index of /ubuntu focal-updates/main amd64 gir1.2-javascriptcoregtk-4.0 amd64 2.38.5-0ubuntu0.20.04.1 [29,3 kB]
Get:7 Index of /ubuntu focal-updates/main amd64 libcurl3-gnutls amd64 7.68.0-1ubuntu2.16 [232 kB]
Get:8 Index of /ubuntu focal-updates/main amd64 libnss3 amd64 2:3.49.1-1ubuntu1.9 [1 256 kB]
Get:9 Index of /ubuntu focal-updates/main amd64 intel-microcode amd64 3.20230214.0ubuntu0.20.04.1 [5 856 kB]
Fetched 31,8 MB in 5s (6 122 kB/s)
(Reading database ... 291864 files and directories currently installed.)
Preparing to unpack .../0-curl_7.68.0-1ubuntu2.16_amd64.deb ...
Unpacking curl (7.68.0-1ubuntu2.16) over (7.68.0-1ubuntu2.15) ...
Preparing to unpack .../1-libcurl4_7.68.0-1ubuntu2.16_amd64.deb ...
Unpacking libcurl4:amd64 (7.68.0-1ubuntu2.16) over (7.68.0-1ubuntu2.15) ...
Preparing to unpack .../2-libwebkit2gtk-4.0-37_2.38.5-0ubuntu0.20.04.1_amd64.deb
...
Unpacking libwebkit2gtk-4.0-37:amd64 (2.38.5-0ubuntu0.20.04.1) over (2.38.4-0ubu
ntu0.20.04.2) ...
Preparing to unpack .../3-libjavascriptcoregtk-4.0-18_2.38.5-0ubuntu0.20.04.1_am
d64.deb ...
Unpacking libjavascriptcoregtk-4.0-18:amd64 (2.38.5-0ubuntu0.20.04.1) over (2.38
.4-0ubuntu0.20.04.2) ...
Preparing to unpack .../4-gir1.2-webkit2-4.0_2.38.5-0ubuntu0.20.04.1_amd64.deb .
..
Unpacking gir1.2-webkit2-4.0:amd64 (2.38.5-0ubuntu0.20.04.1) over (2.38.4-0ubunt
u0.20.04.2) ...
Preparing to unpack .../5-gir1.2-javascriptcoregtk-4.0_2.38.5-0ubuntu0.20.04.1_a
md64.deb ...
Unpacking gir1.2-javascriptcoregtk-4.0:amd64 (2.38.5-0ubuntu0.20.04.1) over (2.3
8.4-0ubuntu0.20.04.2) ...
Preparing to unpack .../6-libcurl3-gnutls_7.68.0-1ubuntu2.16_amd64.deb ...
Unpacking libcurl3-gnutls:amd64 (7.68.0-1ubuntu2.16) over (7.68.0-1ubuntu2.15) .
..
Preparing to unpack .../7-libnss3_2%3a3.49.1-1ubuntu1.9_amd64.deb ...
Unpacking libnss3:amd64 (2:3.49.1-1ubuntu1.9) over (2:3.49.1-1ubuntu1.8) ...
Preparing to unpack .../8-intel-microcode_3.20230214.0ubuntu0.20.04.1_amd64.deb
...
Unpacking intel-microcode (3.20230214.0ubuntu0.20.04.1) over (3.20220809.0ubuntu
0.20.04.1) ...
Setting up intel-microcode (3.20230214.0ubuntu0.20.04.1) ...
update-initramfs: deferring update (trigger activated)
intel-microcode: microcode will be updated at next boot
Setting up libjavascriptcoregtk-4.0-18:amd64 (2.38.5-0ubuntu0.20.04.1) ...
Setting up libcurl3-gnutls:amd64 (7.68.0-1ubuntu2.16) ...
Setting up libnss3:amd64 (2:3.49.1-1ubuntu1.9) ...
Setting up gir1.2-javascriptcoregtk-4.0:amd64 (2.38.5-0ubuntu0.20.04.1) ...
Setting up libwebkit2gtk-4.0-37:amd64 (2.38.5-0ubuntu0.20.04.1) ...
Setting up libcurl4:amd64 (7.68.0-1ubuntu2.16) ...
Setting up curl (7.68.0-1ubuntu2.16) ...
Setting up gir1.2-webkit2-4.0:amd64 (2.38.5-0ubuntu0.20.04.1) ...
Processing triggers for man-db (2.9.1-1) ...
Processing triggers for libc-bin (2.31-0ubuntu9.9) ...
Processing triggers for initramfs-tools (0.136ubuntu6.7) ...
update-initramfs: Generating /boot/initrd.img-5.15.0-60-generic

1 Like

That looks normal. Just standard output of upgrading via apt.

2 Likes

Just to add there was a big security issue with curl a while back. I have had the same curl updates applied to Devuan. :wink:

These are standard library updates. You may not always understand what is being installed, but it is recommended you update regularly. M$ wouldn't tell you what was being updated.... here, you see the dependencies updated, listed by name. It may seem worrisome, but if it's coming from apt, there is a vetting process in order to have and post to repositories. These repositories are screened regularly for malicious code. No worries when you update.