Don't see sound card listed as audio source

Am using Zorin 16 and trying to record some audio. I want to record what the sound card is playing. But everything is very faint.

When I looked at Settings --> Sound, I only see "Microphone - Built-In Audio" as a selectable input source. I can force the input volume way up for the Mic source by using the Settings --> Sound input volume control, but that generates a lot of background noise, and is a clunky work-around.

This mic-only input limit is present whether I use the Settings --> Sound control, the built-in Sound Recorder app, or Audacity (a sound editor). Looks like the OS is only recognizing the Mic.

Is there a way to enable other input sources to be recognized by the OS (in addition to the Mic)?

PS - arecord -l yields:
**** List of CAPTURE Hardware Devices ****
card 0: PCH [HDA Intel PCH], device 0: ALC236 Analog [ALC236 Analog]
Subdevices: 0/1
Subdevice #0: subdevice #0

Hi,

Try with pavucontrol

sudo apt install pavucontrol
1 Like

Thanks Storm. That's better. Now I see two other input sources... 'Internal Microphone (unplugged)' and 'Monitor of Built-in Audio Stereo'. Can now record a decent stream w/o background noise, but regardless of which source I select now (original Mic or either of the two listed above), I only get mono output on the left channel. Using the test function at Settings --> Sound shows the left channel working great and the right channel with no output at all.

Any ideas?

Try see how the settings are in alsa,

alsamixer

image

Looks like there was a bit more there if I widened the window a bit...

Note the arrows on the right side of the window?

Try press [F6] in alsamixer.

Select '0 HDA Intel PCH'?

You could try, I just think it's the default you get as you only have one sound source listed.
I'll call for backup assistance who knows more about soundcard than I do.
@zabadabadoo

1 Like

OK. I appreciate the help.

1 Like

I think you should press F4 to change your capture (recording) source.

Not sure what to do here

Thanks.
@Storm was right.
We need a triage this to @zabadabadoo

Heh OK.

Here is current state...

On a completely different matter, this extension might be of interest of you: Volume Mixer - GNOME Shell Extensions

Okay. After studying the PulseAudio app a bit, I unlocked the 'Built-In Audio Analog Stereo' device by clicking the little lock icon to the right of the component name on the Output Devices tab. That allowed me to see both left and right channels individually, and the right channel control was set to zero (mute). So I matched that slider with the left channel control, and now everything seems to be working properly.

Not sure why that one channel on the device was set to zero since I haven't messed with sound on this (recent) Z16 install until this post. But in any case, it seems to be working ok now.

Thanks to both of you for the assist. And if @zabadabadoo has any additional feedback after reviewing this thread, I'd love to hear it.

3 Likes

@Orion Sorry I have been away since you posted this.
Alsamixeris my favorite tool for checking sound channel settings. But sound problems are often illogical and difficult to diagnose. Would definitely irritate Spock.
Anyhow, I did see from your screenshot above that your headphone output was only outputting on left side. So see you have worked that out and fixed that for yourself. Congratulations.

EDIT: Also see your speakers were [MM] = muted. Is that intentional?