DOTA 2 graphical problems with major stutters

Hello dear friends!

I am new to the Zorin Community. I hope you will forgive if i missed the right topic/section.

I have a problem with dota 2 game. I have major graphical and stutter problems.
I will try to explain you behavior of the game: When the game loads, major stutter begins, (feels like it is struggling to load some resources needed for graphics) after 20-30 seconds it becomes normal but i still see that there is a small stutters. When u enter the match again major stutter begins same as i said before. Later it becomes a little playable but still on low graphics. I tried bunch of options: installed open source mesa drivers and installing proton and steamplay for DOTA2. Nothing has changes i even believe that game worked slightly better when OpenGL option is checked than Vulkan.

I am pretty sure this is graphical problem with a drivers or smth.
If i can get any help i would be very thankful.
I love ZorinOS so much i just dont want to change it to other Distros.

These are my specs: iMac 2010/12GB ram/Mobility Radeon HD 5850/Intel(R) Core(TM) i5 CPU 760 @ 2.80GHz/HDD 1TB + 250SSD/

Big thanks in advance and have a nice day!

Hi and welcome to the forum :slight_smile:

I am not a gamer myself but there are several volunteers here who are knowledgeable about gaming.
I hope some of them come to this thread to help you.
@Michel @StarTreker @Storm

2 Likes

I have more Nvidia knowledge since I use Nvidia based GPU's, have 0 knowledge of modern AMD GPU's. What I do know is, your going to need to make sure you install your driver for your GPU.

I found your driver here...

https://us.driverscollection.com/?H=Radeon%20HD%205850&By=ATI&SS=Linux%20x86_64

Also, is DOTA installed through Steam? Cause if it is, your going to need to use Steamplay Proton compatibility in order to get the game running properly as well.

If your instead playing the game from Lutris, well, only Michel can help you there. I am going to bed, so I am not going to be posting screenshots yet again.

If on Steam, just right click the game, go to properties, compatibility, force steam play Proton version, try latest version, if that don't work well, then go down to the next version until the game is stable.

But make sure you get those video drivers installed if you haven't already.


3 Likes

Radeon card? I'm a nvidia guy, but I know that ATI/Radeon is notorious when it comes to performance compared to Nvidia that is pair with their Windows driver.

1 Like

The radeon 5850 is a old mid range card and his cpu is also old. The last ATI Radeon card i used to have was an Asus Radeon HD4870 and that was back in 2009. Shortly after that the 5xxx series got lauched. Reminds me i customized that card with a twin turbo installed on it.

So for gaming, old games would probably run BUT i don't think their are drivers for it ?

1 Like

You are asking a tough question :sweat_smile:
The last non NVidia I had was ATI GPU (when it was still a Canadian company).

I vaguely remember that I have flashed it with a mod BIOS circulated in a Russian language forum and converted it to the higher spec version (the card was essentially slowed down by software for marketing reasons). It was almost 20 years ago.

Considering there was no such thing as Google translate around that time, I think I was very adventurous/reckless.

1 Like

Sorry for answering late. I tried literally everything you guys recommend me and i searched the internet detailed. I have no solution to this problem. This problem is probably related especially for Radeon 5850 because i saw other people solving problems with only installing mesa drivers which is easy.

So i believe there is actually a cure but it needs some advanced knowledge.

Anyways guys thanks alot i appreciate effort u put in helping!

2 Likes

The only thing you can try

sudo add-apt-repository ppa:oibaf/graphics-drivers
sudo apt-get update

That ppa from what i read is updating ati/amd gpu drivers since 2011. Might be worth a shot.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.