Double Application button in Taskbar

Screenshot from 2022-10-16 12-51-09

Hi there, this is what my taskbar looks like and I am not able to turn off the button that says applications + it isn't doing anything it just displays the apps like the Zoing logo but without the search bar.

I tried to remove it in the taskbar settings but that removes both or none.

Any ideas?

Have you tried installing GNOME extensions and/or GNOME tweaks and finding a setting that disables either application icon?

Hi, yeah I just installed gnome extensions and it shows an error code which I am now attempting to forward to github.

I do have tweaks installed as well I take a look at it.

Can you tell me the error code it tells you?

Sure, so i go to this webpage Installed Extensions - GNOME Shell Extensions
and I get this view.

With these technical details.
The settings of extension gestureImprovements@gestures had an error:

Gtk.BuilderError: /home/hdky/.local/share/gnome-shell/extensions/gestureImprovements@gestures/ui/prefs.ui:30:37 Invalid property: GtkMenuButton.icon-name

Stack trace:

getPrefsWidget@/home/hdky/.local/share/gnome-shell/extensions/gestureImprovements@gestures/common/prefs.js:69:10
buildPrefsWidget@/home/hdky/.local/share/gnome-shell/extensions/gestureImprovements@gestures/prefs.js:12:9
_init@resource:///org/gnome/Shell/Extensions/js/extensionsService.js:207:40
OpenExtensionPrefsAsync/<@resource:///org/gnome/Shell/Extensions/js/extensionsService.js:122:28
asyncCallback@resource:///org/gnome/gjs/modules/core/overrides/Gio.js:132:22
run@resource:///org/gnome/Shell/Extensions/js/dbusService.js:177:20
main@resource:///org/gnome/Shell/Extensions/js/main.js:19:13
run@resource:///org/gnome/gjs/modules/script/package.js:222:19
start@resource:///org/gnome/gjs/modules/script/package.js:206:8
@/usr/share/gnome-shell/org.gnome.Shell.Extensions:1:17

which means nothing to me since I just moved to linux and I am pretty darn new to this. Perhaps you understand more. I also posted this on the github page.

Which layout are you using?

The one at the top left in the free version.

Right click on the taskbar for panel properties, then choose layout and then remove the application plugin. It can also be done by right clicking on it and selecting remove plugin/extension.

Yes i have that also. He must something double or changed on taskbar settings. Your solutions is correct. It also comes if he installing example de with zorin-core-desktop-full then also could be double.

None of those options work as I have done it


I think it has something to do with extensions manager. I just played around with it and noticed the zorin symbol disappear but not the (applications button) that's what I am calling the annoying thing that acts like the zorin logo but with no function.

I also noticed that there is the zorin appindicator giving me this error:

Gio.IOErrorEnum: An object is already exported for the interface org.kde.StatusNotifierWatcher at /StatusNotifierWatcher

and I get the ubuntu appindicator error:

Gio.IOErrorEnum: An object is already exported for the interface org.kde.StatusNotifierWatcher at /StatusNotifierWatcher

Could that have anything to do with it?

Did you using before any testing kde or another DE desktop?
I remember when i have some problems i clicked on apperance Zorin then choose some another DE from Zorin and then all back to default. That means when you choosing some DE from Zorin this propably reseting all things for default. Did you tried that? If not propably some settings or software could do that problem also.

1 Like

have you checked ~/.local/share/gnome-shell/extensions/ to see if that extensions is installed?
If it is installed in Root, it would be /usr/share/gnome-shell/extensions/

Yeah I have extensions installed. I actually reinstalled it yesterday but no difference.

I also noticed that when I plug something into the USB the little triangle doesn't show up in the taskbar and it is supposed to.

There has to be some error in gnome right? As I was also trying to improve gestures for my trackpad. And that hasn't worked.

Could it have something to do with the error codes from ...

I'm sorry, I was not very clear with that.

I was referring to the specific extension:

Yes it is. If that is the extension you are talking about.

Ok, I think at this point, we can presume that the warnings for that extension are unrelated and harmless.
There are lots of apps that throw warnings when things don't go their way...

What you could try is disabling ALL gnome extensions (temporarily) to see if the applications item vanishes from the panel.
If it does, we then know it is an extension.
Re-enable extensions one by one until it reappears- showing which extensions is responsible.

1 Like

Yep that fixed it. I guess coming from mac and then windows to linux I get overwhelmed with the amount of things you can do here. I just had to go to my extensions manager and toggle of the application menu. Doh.

I have that problem with firefox any uninstalling reinstall not help firefox.