Double cursor appearance on desktop

Good evening, I am a new member of the dorum and a new Zorin Os Core user.
My problem is trivial but annoying, let me explain:
often another cursor appears on the screen at a certain point on the screen, like a spot.
Why?
Thanks a lot

Hi and welcome. You are going to have to provide more details than that to get you some help. Perhaps a screenshot? Also - your hardware (type of make, CPU, amount of RAM, SSD or HDD) and what version of Zorin? That way the volunteer folks here on the forum can try to support your issue. Thanks... :v:

1 Like

Welcome to the Forum!

Is it the same Cursor that You use?

P.S: a Screenshot would be nice.

Hello and thanks for the reply.
Here you are:

Hardware_SSD 256gb

Schermata del 2024-05-17 21-42-23

Screenshot for cursor:
IMG_0184

Thanks a lot!

Yes, it's the same cursor

IMG_0184

I had to take photos with my smartphone because when I took a screenshot the "double cursor" disappeared

Okay, thank You for the Pictures.

First I would suggest to test if it is a Wayland/Xorg Issue. To control that go to the Login Screen. Click on You Profile so that the Password Field appears. It is important that it appeard. Then You see in the bottom right Corner a Gear Icon. Click on it. There You should find 2 Option:

  1. Zorin Desktop (that is the Wayland Option)
  2. Zorin Desktop on Xorg

Which Option is active You can see from the Point Marker. By default it should be the first One. So, change from the active One to the other One by clicking on it and then log in and test if it works.

Thanks for the reply.
It seems to be going well and the problem is solved.

Should I delete Wayland?
If yes, what should I do?

Thank you

Leave it alone. Just use X11 and Wayland is there if you ever need it.

1 Like

Could this be a problem?
Thanks for the reply

Ho visto questo discussione in cui suggerivano questo metodo:
Schermata del 2024-05-18 21-46-20

Wayland is a feature like X11. It is not a problem. Wayland is the future for display management. But for some hardware it can be troublesome. That is why Zorin includes both Wayland and X11. Just use X11 if that works better.

1 Like

You can do it, but You don't have to. When You change it in the Login Screen it should stay.

No, let it like it is and simply use Xorg. That is the simpliest Way.

Thanks to both of you for the replies.
Mine was a curiosity whose aim was to avoid having to choose between the two at every access :smile:
But nothing can be done

You don't have to choose it on every Access. When You change it once it stays there so long until You change it again. Or falls it back on Your Machine? If yes, then You can make the Change in the custom.conf File.

1 Like

That's fine, I'm only answering now because I wanted to test the system with xorg and it's no longer giving that annoying "problem".

Thanks for the support.

See you soon

1 Like