Download Logitech media server

Hi, first Time here,
I have been trying to install Logitech Media Server from Slimdevices but it will not download the file. No other problems downloading in general. Downloaded the file from Windows PC and put on a USB stick and tried to install from there but again no joy.
I did try to install Windows style by double clicking.
How can I install Logitech Media Server the file is written in Pearl
Thanks for any help

I just downloaded the logitechmediaserver_8.1.1_amd64.deb from


and it installed from double click without any issues.
Could you please give more details on what you mean by “no joy?” What is it doing? Does nothing at all happen on double click?
Have you tried installing it from terminal?
Did you check your download to ensure the correct version?

EDIT The Above…
Installing Logitech Media Server broke my apt. It created a bus error that prevented any new installations, crashed Synaptic and disallowed access.
I had to fix and rebuild using the following lengthy string of commands.

sudo fuser -vvv /var/lib/dpkg/lock
sudo rm /var/lib/apt/lists/lock
sudo cp -arf /var/lib/dpkg /var/lib/dpkg.backup
sudo cp /var/lib/dpkg/status-old /var/lib/dpkg/status
sudo cp /var/lib/dpkg/available-old /var/lib/dpkg/available
sudo rm -rf /var/lib/dpkg/updates/*
sudo rm -rf /var/lib/apt/lists
sudo rm /var/cache/apt/*.bin
sudo mkdir /var/lib/apt/lists
sudo mkdir /var/lib/apt/lists/partial
LANG=C;sudo apt-get clean
LANG=C;sudo apt-get autoclean
LANG=C;sudo apt-get --purge autoremove
LANG=C;sudo apt-get update -o APT::Cache-Limit=25165824
sudo dpkg --clear-avail
sudo dpkg --configure -a
LANG=C;sudo apt-get -f install
LANG=C;sudo apt-get --fix-missing install

My recommendation on installing Logitech mediaServer:
DON’T.

1 Like

Wow, but funny enough yesterday I tried downloading from this same page half a dozen times and nothing happened, from your link same page bingo first go.
It tells me it is installed but I have no Icon to launch it, don’t know where to look for it.
Sorry trying to help me stuffed up your system, lucky you know what you are doing.

I had the same experience.
I tried a second time (On account of my Suicide Linux mentality) by downloading the package and installing it by

sudo dpkg -i logitechmediaserver_8.1.1_amd64.deb

It installed, after some odd behaviors in my terminal. Then it said that ureadahead would be profiled on next reboot. Rebooted - could not find the app, could not find an icon, running from terminal did not work and yet- in my conky, it showed as an Active Process that was running. Opened SysMon and it did not show it at all.

Then I had to repeat all the steps above…

So- yes, I stand by my comment above: Logitech has a severely broken package that can really mess up the user.
Also- if you installed that, you might check if you have a gremlin in the machine and try installing something like

sudo apt install tree

and see if you get a bus error or not.