Dpkg error on every install and updates

This thing doesnt allow me to do any installs, any updates, and any upgrades I do. Everything keeps failing because of this. Is there a fix for this? Im getting very mad with this. It also has this at the end;
Errors were encountered while processing:

Can you try

sudo dpkg --configure -a

Have you checked your sources?

In Software & Updates, is your Download from set to "Main Server?"

Sidenote: The frustration you are feeling is something I think we can all identify with. Years of computer use - and every once in a while, we really just want to go full Hulk and smash everything to pieces.
The only way I have found to navigate it is to focus on each step of trying solutions rather than the problem as a whole. I think it may be because our minds manage things better in less overwhelming portions.

1 Like

YES I 100% agree with that. It is very frustrating to deal with these errors again and again. Just solved one problem, here comes another. Especially with older hardware like this. It is very infuriating and makes me want to smash it all, but I fully know that if I do that I'll just make everything worse and I cant afford a replacement for it. Very frustrating indeed.
Anyways, when doing sudo dpkg --configure -a it still shows me this error.
As for the downlaod from, it says custom server so I'll switch it to Main server rn. Hope this fixes it because I've been pulling my hairs out from this.

Thanks for the advice btw. I think its just because Im still new to this that I get easily frustrated. Thanks for the help too, Idk where i'd go for help if this forum doesnt exist. You guys do a lot of heavy lifting for us noobs.

Switch, then allow it to refresh. Then in terminal run

sudo apt update && sudo apt upgrade

Once done, reboot.
Then in terminal run:

sudo apt --fix-broken install

Once that is run - check where you stand. The above steps should help resolve some things in the background but do not expect it will cure and fix everything just yet.

Quick Question:
Are you on Zorin OS 17?
Zorin OS 16 is solid and reliable and will still be supported for years, yet and can be run longer than that.
I am still using Zorin OS 12 (Yes 12) on my oldest machine (That I use in the shop for automotive diagnostics) because that little Toughbook is so old, it performs properly on the older edition.
Zorin OS 15 would work on it, too but why bother?
If using 17, you might be a lot better trying 16 Lite on it.

1 Like

I've tried both the commands and so far everything is going well. No errors I've been seeing except maybe this?

Oh I am at os 17 core rn. Read somewhere that Lite is designed with 32bit computers in mind(?), and a 64bit computer would be better off with core. Idk about this one, is this true? And also I thought that a newer version basically means less bugs in it and more additional softwares/features. If I'm not really gonna sacrifice a lot then I might switch to 16 lite for even better performance. But so far everything is snappy and fast at loading.
I also just got through 3 reinstallations since yesterday, quite the hell dpkg error put me through. That also explains why the 62mb package I downloaded earlier took like 1.5 hours. Thanks again btw

No, no... not at all. 32 bit support on Zorin OS ended at Zorin OS 15 Lite is all. So Lite extended 32 bit support for some users.

1 Like