Drag and drop issue - Zorin OS 16.2

Good morning, afternoon or evening. I hope you are having a good midweek.

I'm new to the Linux world and I'm very happy with the experience it has given me so far. A couple of months ago I migrated to Ubuntu from Windows 10, specifically to version 22.04.2. The animations and the fluidity of the system are something that I had not seen before and that I loved from day one.

However I started to have performance problems which forced me to switch to Zorin OS 16.2. The improvement in stability was considerable, but I started to have a very particular problem.

The file explorer, (Nautilus) does not allow me to drag and drop files in Telegram or Discord, except in very specific situations. From the app's internal explorer it only recognizes the images folder, the videos folder and the documents folder in the user directory. If I try to drag files from those options there is no problem, but if I try from one that is not there, for example the desktop, it does not work. It gives the following error message: "The file is empty and cannot be sent".

I thought it could be some incompatibility with Zorin because in Ubuntu this problem didn't happen; then I tried Linux Mint and surprise, exactly the same.

At this moment I'm trying again the live image of Ubuntu 22.04. to confirm that it doesn't fail. In the meantime, any idea what could be wrong?

What method did you use to install Discord? Is it a flatpak?

flatpak list

I have no troubles with this using the .deb standard package supplied.

1 Like

Yes, it is installed from the Gnome Software via Flatpak, maybe that's the problem?

It may be yes. Flatpak is sandboxed, limiting access.
You might get it to work with Flatseal

Or remove the flatpak and install the .deb package. I use the .deb combined with Better Discord package.


I am having the same problem in discord, telegram and whatsapp. I use all of them from firefox. I am unable to drag and drop images in any of these platforms. I have to open the image from nautilus, copy it and paste it in my browser.

1 Like

If you downloaded the applications from the store you probably have the same problem as me. Downloading the official .deb or installing from the terminal should solve the problem.

Thank you! Removing the flatpak version and installing from the official repositories solved the problem.

Now Zorin works perfectly :1st_place_medal:

I tried to remove those restrictive OS permissions but it's too complicated for me and I don't want to break anything.

1 Like

Please open a new thread concerning your restrictive os permissions. Please also include more detail to which permissions you are referring and what you are attempting.

@AlterNezKo is referring to my post in which I made two separate suggestions. One of them was:

To which @AlterNezKo replied:

and opted instead to:


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.