Dual Boot - can not find windows


i installed Zorin OS 16 along with Window 10 on my Asus n76vz. Now my laptop directly boots into Zorin. I tried to search Windows with grub and os-prober but can not find it. It does not even show in the BIOS anymore. I installed Zorin on first Hard Disk and Windows is still on the second hard disc:

I additionally tried:
sudo add-apt-repository ppa:yannubuntu/boot-repair
sudo apt-get update
sudo apt-get install -y boot-repair && boot-repair

and it said to me that "LegacyWindows was found. Please enable BIOS-compatibility/-
CSM/Legacy mode in your UEFI firmware, and use this
software from a live-CD (or live-USB)."

Since I am new to Linux and I do not really know what it means. Where is my problem and how I can fix it to run both systems? I also do not have a windows live-CD or DVD.

Thank u for ur support

Kind regards

Hi and welcome to the forum :slight_smile:

Make sure you install Windows and Zorin in the same mode.
Either legacy BIOS or UEFI.
But not both.

Thank u for the fast reply. :slight_smile: So I need to find space on my hdd, make a new Zorin USB drive for legacy BIOS and install it in this free space. And in the end delete the Zorin UEFI version and give this space to the Zorin legacy BIOS version?

You could simply delete the unwanted partition provided you do not have any personal data on it. In that case, you need to backup your personal data first before deleting the partition.

Okay but when installing Zorin, where is the point where I can choose between UEFI and legacy BIOS? What do I need to do now?

If you are using Rufus to create the installer USB,
you can choose MBR scheme:
See for ex.

When you start laptop and hold F8 what do you see F8 is boot option. You should have list available bootable drives. I think that Windows install in uefi mode by default.Installing Zorin in MBR will not work. From live install, use gparted and from Device choor GPT partition. Then in Rufus choose GPT. That should put both os on the some level

Marked solution. 70

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.