Dual booted ZorinOS wont connect to wired internet

I'm using Zorin 17

I'm plugged in straight into the router, no WiFi. It shows the internet as "Cable disconnected" even though it's definitely not disconnected. When in windows the internet works perfectly fine, issue is only present in Zorin. I've tried unplugging and plugging in the cable but it only fixed the problem once. After restart not even that fixes it. Tried booting in recovery mode to run dpkg, it didn't fix the issue either. Also this issue appeared out of nowhere, I've been using Zorin for 2-3 days now and this is the first time it has started happening. There were no updates or anything before it started happening.

So far I've also tried this solution and it only worked temporarily. After restart the internet is broken again, only this time the networkplan.yaml didnt disappear, its still there, unchanged.

I haven't installed any updates or any drivers or anything out of the ordinary. It appeared out of nowhere

Try to connect to the router's dashboard from another computer and see if the computer running ZorinOS is being detected there. Since it's typically a web-based dashboard you can do this through your phone as well. While you are at it, try to ping the other machine from either computer to see if there's any traffic locally. Also check for any router-based firewall rules blocking access.

To find out the IP address provided by the router run ip a and search for the interface named something along the lines of eth0 or enp1s0:

A few things you can try is switching to another physical connector in your router, changing the cable, etc. It's strange that it works sometimes but suddenly it looses connection. And does the Wi-Fi work normally?

Have you checked that IPv6 has been disabled? Sometimes this has solved the issue for other users:

Also, as you are dual booting, ensure that Windows Fully Shuts Down.

Windows likes to hibernate when you tell it to shut down, in order to give the appearance of a "Fast boot".
When Windows hibernates, it can retain control of some hardware even if you boot into Zorin OS, rendering that hardware inaccessible.

Really? How could I shutdown fully a Windows machine, are there any "tells" that thsi is happening or something needs to be configured to that end?


It is a setting that enables Windows to "Hibernate" when the ShutDown button is used.

1 Like

Fast boot is disabled but still no internet unfortunately

I disabled it but still no internet sadly

Sorry for phone picture, I have no way of sending a screen shot to the internet lol. For some reason I don't have that whole second part that you have in your screen shot

From the looks of it the network interface is down so it has no IP address assigned. With the ethernet cable connected, try to bring it up:

sudo ip link set enp6s0 up

Just to rule things out: have you installed or enabled anything that monitors the network? A firewall, network monitor of some kind, VPN, etc.

Hmm sadly the terminal command didn't change anything, didn't get any errors either. Tried rebooting afterwards as well still no luck. I have not installed anything other than discord, vlc and fractals as far as I can remember. Definetly no VPNs, monitors, firewalls.

What is your terminal output for

sudo lshw -C network

Disable Windows Fast Startup and similar features, like hybrid sleep.

Microsoft does a good job at breaking features in other operating systems through these, and more often than not simply disabling these two fixes various issues caused by how Windows offloads stuff and NTFS. powercfg /h in an Admin-CMD may be of use

Yes I know it sounds bizzare that some filesystem feature would break WiFi, but I've seen this work before so it may be worth a shot :person_shrugging:

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.