Dual Monitor/TV Not Working

Please help if possible determine why my TV monitor linked to Comp is no longer working.

I have no idea what happened. Zorin doesn't even 'see' it anymore. Perhaps I missed an update.

*Note. When I hook up my old Windows 7 drive, the TV comes up just fine so I'm assuming it can't be the Video Card.

Many Thanks in advance.

I had this last week and it was a problem with the video drivers.
I eventually fixed it by removing the nvidia drivers, I tried the open source ones and it started working again, so I then changed them back to nvidia and it still worked.

I believe I started to have problems after a BIOS update as ASUS turned secure boot back on then something seems to have caused the video drivers to get corrupted. So just a suggestion of some things.

Any chance you can link where to find them, or how to load them?

Because Zorin is based on Ubuntu, you can use the same guides: https://www.cyberciti.biz/faq/ubuntu-linux-install-nvidia-driver-latest-proprietary-driver/

No go:

Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to locate package nvidia-driver-510
E: Unable to locate package nvidia-dkms-510

You need to add a repository for this:
sudo add-apt-repository ppa:graphics-drivers/ppa

Try with 440 first:
sudo apt install nvidia-driver-440

Added:

sudo add-apt-repository ppa:graphics-drivers/ppa

Got/Reply:

Fresh drivers from upstream, currently shipping Nvidia.

Current Status

Current long-lived branch release: nvidia-430 (430.40)
Dropped support for Fermi series (List of Fermi series GeForce GPUs | NVIDIA)

Old long-lived branch release: nvidia-390 (390.129)

For GF1xx GPUs use nvidia-390 (390.129)
For G8x, G9x and GT2xx GPUs use nvidia-340 (340.107)
For NV4x and G7x GPUs use nvidia-304 (304.137) End-Of-Life!

Support timeframes for Unix legacy GPU releases:
https://nvidia.custhelp.com/app/answers/detail/a_id/3142

What we're working on right now:

  • Normal driver updates
  • Help Wanted: Mesa Updates for Intel/AMD users, ping us if you want to help do this work, we're shorthanded.

WARNINGS:

This PPA is currently in testing, you should be experienced with packaging before you dive in here:

Volunteers welcome!

How you can help:

Install PTS and benchmark your gear:

sudo apt-get install phoronix-test-suite

Run the benchmark:

phoronix-test-suite default-benchmark openarena xonotic tesseract gputest unigine-valley

and then say yes when it asks you to submit your results to openbechmarking.org. Then grab a cup of coffee, it takes a bit for the benchmarks to run. Depending on the version of Ubuntu you're using it might preferable for you to grabs PTS from upstream directly: Phoronix Test Suite - Download

Share your results with the community:

Post a link to your results (or any other feedback to): Testers of the graphics-driver PPA in Launchpad

Remember to rerun and resubmit the benchmarks after driver upgrades, this will allow us to gather a bunch of data on performance that we can share with everybody.

If you run into old documentation referring to other PPAs, you can help us by consolidating references to this PPA.

If someone wants to go ahead and start prototyping on software-properties-gtk on what the GUI should look like, please start hacking!

Help us Help You!

We use the donation funds to get the developers hardware to test and upload these drivers, please consider donating to the "community" slider on the donation page if you're loving this PPA:

More info: https://launchpad.net/~graphics-drivers/+archive/ubuntu/ppa
Press [ENTER] to continue or Ctrl-c to cancel adding it.

Please advise:

Many thanks in advance.

Just to return to this, slightly, sorry too slow.

What I did to get the right drivers to load I went into software updater and clicked on "Additional Drivers" then chose the x.org drivers, which as I said made it work and then switched back to the correct nvidia drivers.