Dual monitor

Please help my second monitor will not connect ive tried everything but still nothing

Can you please post the Make and Model of the computer and of the secondary monitor.
Can you give a brief list of what you have tried?
We also need to know your Zorin OS Edition (Core or Lite) that you are using:

1 Like

I have tried unplugging and repluging i have tried checking the display settings I have tried changing the monitors settings and it is a Samsung c24rg50fqn

Have you tried the refresh rate at 144hz or 240hz?
Are you using Nvidia Card?

Im at 120 Hz

I have an Nvidia 1650

Ok, and which driver are you using for the 1650?
Software & Updates > Additional Drivers

Can you try testing on 144hz or 240hz and see if it works.

Im using a laptop aswell

I cannot go higher than 120Hz Nvidia driver 510

You may need to try doing it manually...
In terminal please run


Note your Device ID. FOr example, if using HDMI connection, it may show as HDMI1. Grab your Screen resolution, as well.
Adjust this terminal command for xrandr, replacing the resolution and monitor ID to match yours:

xrandr --output HDMI-1 --mode 1920x1080 --rate 144.00

It did not work

it said output HDMI-1 failed ignoring

Are you using port HDMI1?
If so, try

xrandr --output HDMI1 --mode 1920x1080 --rate 144.00

It still did not work

It had same result

Also how do i use a flashdrive for extra storage

You have not yet answered as to your Computer Make and model nor what version of Zorin OS you are using.

These details are important... For example, troubleshooting your machines HDMI or... IF you are using Zorin Core, you would next look at troubleshooting GDM. IF you are using Zorin Lite, you would look at troubleshooting LightDM.
LightDM and GDM are both Display Managers.

I have an acer nitro 5 and im using Zorin OS 16.1 Core

and i need usb stick help

Just a suggestion .... try fixing one problem at a time other wise it can get very confusing for everyone involved ..... after you get your monitor fixed you can open another thread for you USB problem .....


Can you please run:

sudo dpkg-reconfigure gdm3

Follow the prompts.
If that fails, please try using a Different Nvidia Driver, including testing the Nouveua Open Source driver.
If none of the above works, it may not be a driver issue... Check the HDMI cable and port. Some HDMI cables are one-way and must be plugged in correctly - so try reversing the cable direction.
Or if able, try a different HDMI Cable.

1 Like