DVD Movie Trouble. I tried everything

Hello everyone,

I am still a new Linux user but catching on well. However, I am having trouble playing a clean USA NTSC region DVD movie of Star Wars The Phantom Menace In parole and also vlc. I tried everything from installing libdvd-pkg to updating, upgrading, and rebooting left and right! I even installed the css dvd lib even though and article said I did not need to. If it helps my Laptop DVD drive is a MATSHITADVD-RAM UJ8D3 (1.00) and is in /dev/sr0 (Read-Only). There has to be something i am missing... Thank you all for your time.

Have you yet tried:

sudo apt-get install ubuntu-restricted-extras

Yes Absolutely.

Hmmm...
You may need to:

sudo dpkg-reconfigure libdvd-pkg

Follow the prompts and if you get an error for libdvdread4, then run:

sudo apt install libdvdread7

No error was given.
just this:

libdvd-pkg: guest package [libdvdcss2/1.4.2-1~local] is already installed.

guest package - are you running in VMWare?

no my os zorin os lite is running on my physical laptop and fully installed. no windows. am I using the wrong terminal? I use 'terminal emulator' that comes with the os

I just was checking on that package name.
Otherwise, I am at a loss as to what is causing the issue.

Ok well thank you anyway. I suppose I'll wait if anyone else has any advice regarding this.

I don't know if this reply only Zorin 16, but try anyway;

sudo apt install zorin-os-restricted-addons zorin-os-restricted-extras

I guess you followed this?

Doubleposting :stuck_out_tongue:

Try also physically clean the DVD drive if possible like a can of compressed air. Better yet, a DVD cleaner if you can get your hands on one. and make sure that there aren't any dirt on the DVD.

Alright I'll try cleaning my DVD drive when I can. and yes I did read that It's FOSS article. I also tried

sudo apt install zorin-os-restricted-addons zorin-os-restricted-extras

and update, upgrade, and reboot and my DVD still wont play.

What about other DVDs?

I tried Terminator 2: Judgement Day and a home made burned DVD, neither played. Do I need a special codec or something that I might not know about?

Nope, the steps you've done should be sufficient and my DVD player plays anything I throws at it, so I'm bit baffled.

Is the DVD player plugged in...?

absolutely because i can hear it make noise when i insert a dvd and when i click eject icon it ejects the drive.

I am sure you see my train of thinking here, though. You already tried as much as you could software side.
I am wondering if the issue is hardware related.
Over time, the lens over the laser gets a little cloudy. The usual 'solution' is to increase the power to the lens using the potentiometer, if the manufacturer included an adjustable one.

I suppose I will see what I can do then on the hard ware side. I'm not sure what else to do. When I had windows on this same laptop it worked great but I guess linux works differently. Thank you all so much for your time and help, Ill see what I can do from here on out.

Here is what I do to watch DVD's in Linux and this works every time.

sudo apt-get install libdvd-pkg

First time install, click yes both times activate line below.

sudo dpkg-reconfigure libdvd-pkg

Reboot afterwards

Also make sure you have ubuntu-restricted-extras and ffmpeg installed.

You'll need all of the above also if you're ripping DVD's with Handbrake.