Electron Apps not working

I cannot seem to get any Electron apps working. This includes Spotify and Slack. I uninstalled and reinstalled these two apps multiple times, tried installing them from Snaps and .deb files but to no avail. I tried launching them from the command line in verbose mode and there was nothing in the logs to indicate that something was broken. I was about to embark on a complete reinstall but I figured I would check here and see if anyone had a similar experience if (luckily!) there was a fix of some sort so that I didn't have to go through the hassle of a complete reinstall.

TIA!

Can you clarify what you mean by "not working?" Are they not launching? Are they launching and everything seems normal, but not connecting?
Are they freezing?

I found this report:

@Aravisian Thank you for replying!

They seem to launch but there is no app window visible. I see the app on the task bar and I see a border expanding and minimizing but I don't actually see the window itself.

I will take a look at the github issue. Thank you for pointing it out to me.

Tried launching the apps with --disable-gpu and that didn't seem to help. But it seems like this might be tied to the GPU driver. I might try downgrading my GPU drivers and see if that helps any.

1 Like

I have slack installed for school, use it regularly on Zorin 16 Pro without issue. I used the .deb installation method. The kernel was updated to 5.11.32 or 34 today and still works without issue.

Edit:
After reading some of the bug reports I'm unsure if they ever got this fixed. It's specific to the Intel 916 card. Seems it's been an issue since kernel 5.5 if not a little before. I hope downgrading the driver works because the only other solution was to downgrade the kernel to 5.4 (before zorin 15.3).

1 Like

Thank you!

I have a 3080Ti - Downgrading to a previous stable version of the nvidia custom drivers did not help and neither did the nouveau drivers. But it does seem like its GPU drivers related.

I have an old GT710 lying around somewhere. I will try swapping out the card temporarily to see if that works - I am not hopeful to be honest and mostly grasping at straws here - the card would use the same drivers as the 3080Ti.