Enabling Bluetooth & WiFi

Hello. I am needing some help! I am a complete newbie to Linux and to ZorinOS. I installed the free version on an old computer and everything worked without any issues. I was quite pleased and impressed with the OS so I decided to purchase the Pro version and had it on my daily driver. Thankfully I dual booted so I can still use Windows but want to fully embrace Linux and be done with Windows and Macs.

I use an Acer Aspire A315-24PT. My bluetooth and wifi works just fine on the windows version but on Zorin, it does not. I have tried following multiple articles on how to check and enable bluetooth. Everything failes. I am at a loss now and not sure of what to do from this point.

Any help and advice would be amazing! I look forward to hearing from the Zorin Community.

UPDATE: I thought I would add that I have a wifi dongle that I connected via USB and it will connect the computer online. I am needing to get my onboard wifi and bluetooth to work.

This is a bit of a long reply with multiple parts to it and several links thrown in, so please bear with me.

  1. If you're dual-booting Windows, please check for and disable both "fast boot" and "fast startup". One is a Windows setting and the other is a BIOS / UEFI setting you may or may not have; whether your BIOS / UEFI has the option, and where to find it if so, I can't say. Unfortunately, every BIOS and UEFI is totally different, using different names for the same features even within the same brand!
  1. Now, check the output of lspci and sudo lshw -C network to make sure Zorin is actually seeing your wifi card at all, and check what driver its trying to use. When you know that, it will be easier to search / ask for specific help for your exact chipset.

  2. Run the command rfkill list all in a terminal and see if your WiFi devices are blocked at all. If so, try sudo rfkill unblock all and then run rfkill list all again to see if it changes.

  3. I have also seen some mention previously of an Acer kernel module that can block certain WiFi drivers, even on machines from other brands like ASUS and HP. If you see acer_wmi or acer-wmi in the output of sudo lsmod | grep acer then it may be worth trying this fix. WMI modules are for mapping the Fn keys on laptop keyboards to system functions, such as toggling WiFi or changing screen brightness. If the chosen WMI for your keyboard is broken or the wrong one - such as acer-wmi on a Dell or HP laptop - this somehow causes the WiFi driver to fail / be blocked in the system. Why? I have no idea, it just does! :joy:

1 Like

Thank you Ultrabenosaurus for replying to my forum topic. I tried everything in your list and I hate to admit it but it is all Greek to me. So I thought I would share what I saw down below for your review and hopefully next steps.

  1. I doubled checked and make sure that Fast Boot and Fast Startup are disabled. Only Secure Boot is enabled.

  2. I checked the lspci and sudo lshw -C and this is what came up:

LSPCI:
lspci
00:00.0 Host bridge: Advanced Micro Devices, Inc. [AMD] Device 14b5 (rev 02)
00:00.2 IOMMU: Advanced Micro Devices, Inc. [AMD] Device 14b6
00:01.0 Host bridge: Advanced Micro Devices, Inc. [AMD] Device 14b7 (rev 02)
00:02.0 Host bridge: Advanced Micro Devices, Inc. [AMD] Device 14b7 (rev 02)
00:02.2 PCI bridge: Advanced Micro Devices, Inc. [AMD] Device 14ba (rev 02)
00:02.3 PCI bridge: Advanced Micro Devices, Inc. [AMD] Device 14ba (rev 02)
00:08.0 Host bridge: Advanced Micro Devices, Inc. [AMD] Device 14b7 (rev 02)
00:08.1 PCI bridge: Advanced Micro Devices, Inc. [AMD] Device 14b9
00:08.3 PCI bridge: Advanced Micro Devices, Inc. [AMD] Device 14b9
00:14.0 SMBus: Advanced Micro Devices, Inc. [AMD] FCH SMBus Controller (rev 71)
00:14.3 ISA bridge: Advanced Micro Devices, Inc. [AMD] FCH LPC Bridge (rev 51)
00:18.0 Host bridge: Advanced Micro Devices, Inc. [AMD] Device 1724
00:18.1 Host bridge: Advanced Micro Devices, Inc. [AMD] Device 1725
00:18.2 Host bridge: Advanced Micro Devices, Inc. [AMD] Device 1726
00:18.3 Host bridge: Advanced Micro Devices, Inc. [AMD] Device 1727
00:18.4 Host bridge: Advanced Micro Devices, Inc. [AMD] Device 1728
00:18.5 Host bridge: Advanced Micro Devices, Inc. [AMD] Device 1729
00:18.6 Host bridge: Advanced Micro Devices, Inc. [AMD] Device 172a
00:18.7 Host bridge: Advanced Micro Devices, Inc. [AMD] Device 172b
01:00.0 Non-Volatile memory controller: Sandisk Corp Device 5017 (rev 01)
02:00.0 Network controller: MEDIATEK Corp. Device 7902
03:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Device 1506 (rev c1)
03:00.1 Audio device: Advanced Micro Devices, Inc. [AMD/ATI] Device 1640
03:00.2 Encryption controller: Advanced Micro Devices, Inc. [AMD] VanGogh PSP/CCP
03:00.3 USB controller: Advanced Micro Devices, Inc. [AMD] Device 1503
03:00.4 USB controller: Advanced Micro Devices, Inc. [AMD] Device 1504
03:00.5 Multimedia controller: Advanced Micro Devices, Inc. [AMD] Raven/Raven2/FireFlight/Renoir Audio Processor (rev 6f)
03:00.6 Audio device: Advanced Micro Devices, Inc. [AMD] Family 17h (Models 10h-1fh) HD Audio Controller
04:00.0 USB controller: Advanced Micro Devices, Inc. [AMD] Device 1505

sudo lshw -C
Hardware Lister (lshw) -
usage: lshw [-format] [-options ...]
lshw -version

-version        print program version ()

format can be
-html output hardware tree as HTML
-xml output hardware tree as XML
-json output hardware tree as a JSON object
-short output hardware paths
-businfo output bus information

options can be
-class CLASS only show a certain class of hardware
-C CLASS same as '-class CLASS'
-c CLASS same as '-class CLASS'
-disable TEST disable a test (like pci, isapnp, cpuid, etc. )
-enable TEST enable a test (like pci, isapnp, cpuid, etc. )
-quiet don't display status
-sanitize sanitize output (remove sensitive information like serial numbers, etc.)
-numeric output numeric IDs (for PCI, USB, etc.)
-notime exclude volatile attributes (timestamps) from output

  1. I ran the rfkill list all and this is what I found:
    0: hci0: Bluetooth
    Soft blocked: no
    Hard blocked: no
    1: acer-wireless: Wireless LAN
    Soft blocked: no
    Hard blocked: no
    2: acer-bluetooth: Bluetooth
    Soft blocked: no
    Hard blocked: no
    I am assuming that this means that the wifi and bluetooth are not blocked.

  2. When I did this one, this is what came up:
    acer_wmi 36864 0
    sparse_keymap 12288 1 acer_wmi
    acer_wireless 16384 0
    video 73728 2 acer_wmi,amdgpu
    wmi 40960 3 video,acer_wmi,wmi_bmof

I appreciate your help and look forward to getting this resolved.

Unfortunately, it looks like this wifi chip is too new and there is no linux driver for it yet. The MediaTek driver page on kernel.org was last updated 9th May 2024 and does not list 7902.

https://wireless.wiki.kernel.org/en/users/drivers/mediatek

You can see here other people asking on various linux forums, and I can't see any sign of a fix. Everyone just buys a new wifi adaptor - either a USB dongle, or a replacement M.2 card if their MT7902 is installed that way (instead of soldered) and they don't mind about voiding their laptop warranty.

It's a bit of a longshot, but you may be able to install the Windows drivers on Zorin via ndiswrapper. I'll drop a link to the (rather old) Ubuntu help guide, but the basic steps are:

  1. Download the official Windows drivers and extract them, if there is a .inf and a .sys file then you have a chance.
  2. Open a terminal in the extracted driver folder and run sudo ndiswrapper -i <DRIVERNAME>.inf (with the filename of the .inf).
  3. Run ndiswrapper -l to check if it installed correctly.
  4. If it shows as installed, tell Zorin to actually load the module by running sudo depmod -a followed by sudo modprobe ndiswrapper. I'm not sure if you will need to reboot your laptop for it to take effect.

https://www.acer.com/gb-en/support/product-support/Aspire_A315-24PT

https://help.ubuntu.com/community/WifiDocs/Driver/Ndiswrapper

When I extract the zip, I found these two files. Would that work?
Screenshot from 2024-07-06 16-11-43

When I try to run that command, it says "sudo: ndiswrapper: command not found"

This is what I entered, is it correct? sudo ndiswrapper -i mtkwl6ex.inf

Those are the files you need; it might work, it might not. ndiswrapper is an old tool from the Dark Ages of linux wifi and was the go-to solution back then, but has been less and less relevant thanks to great efforts from the linux kernel team, and in particular the late Larry Finger, so I'm not sure how maintained or effective it still is, especially for new chips. It's certainly worth a try, though.

You ran the correct command, but ndiswrapper is not installed on your machine. Assuming it is even still available these days, you should be able to install it with this command:

sudo apt-get install ndiswrapper ndiswrapper-utils

Yeah, I tried it and it was unable to locate the package. For now, I will purchase a bluetooth and wifi dongle. Hopefully they will update the kernals so that I can use the onboard ones. I really am liking Linux. It is very fast and responsive compared to windows.

Do you know of any resources or courses I could look into to learn more about Linux?

Again, thank you for your help. I do appreciate your time.

Sorry I couldn't get your wifi working. The closed, secretive nature of drivers and the manufacturers' lack of support for linux is honestly infuriating :angry:

As for courses, I don't have anything specific to recommend. I don't learn particularly well by following rigid, prescriptive courses and such; I find it difficult really grasping and applying generic concepts without a real-world problem to throw them at. I typically wait until I have a specific problem and thenjust attack search engines and forums until I figure stuff out the hard way :sweat_smile:

I would say that unless you want to achieve something more technical and specific, courses are probably unnecessary, and most are focused on the command line rather than graphical / visual software and general desktop use anyway.

In terms of day-to-day usage for the average consumer, driver issues aside, modern desktop linux isn't really that much different than Windows or Mac: you have files and folders, OS app stores, direct-downloadable software, mainstream web browsers like Firefox and Chrome, even Steam games have pretty amazing compatibility these days. The only real problem, for most, is lack of big-name proprietary stuff like Adobe and MS Office, but there are linux alternatives if you have the time and drive to adapt to them - at least in terms of Office software, the differences aren't huge, just a bit awkward at first.

If you do want to become more comfortable with the command line, the main resource I'd recommend is Linux Journey:

https://linuxjourney.com/

Bold mine...

Would Secure Boot also cause issues with wifi on an already-installed Zorin? I've only ever experienced Secure Boot causing problems booting into live environments and the initial installation, never personally had it cause driver issues. Especially as OP's wifi chip doesn't seem to have drivers in the kernel yet, I figure Secure Boot probably isn't an issue here?

Yes, Secure Boot can cause driver issues should the driver be unsigned. An unsigned driver will not be allowed to init if Secure Boot is enabled in BIOS settings.
This is also true for an unsigned kernel: Secure Boot will not allow the kernel and its mass of hardware drivers to init should it be enabled and the user have an unsigned kernel.
This has been a notorious problem with Nvidia drivers as well...

Unless Secure Boot is absolutely necessary for use on a Dual Boot Windows Machine, it has no valid purpose on GnuLinux and should be disabled. If left enabled by the user, checking performance with it disabled and re-initializing the drivers is a good first action to take.
Even if it is not the cause of the WiFi issue, checking this may prevent other unrelated headaches later, anyway.

2 Likes

Good to know, I'll add this to my standard wifi troubleshooting steps from now on :+1:

1 Like

I have disabled the secure boot. Is there anything I could try to see if I can get the bluetooth and wifi going?

No worries. I appreciate you helping me.

1 Like

I have noticed that my computer will freeze up randomly. It happens twice or three times a day. It lasts for a couple of seconds and then I am able to keep working. At least twice, since I have installed the OS (about 3 days ago) it has gone completely black and I have to press and hold the power button to shut it down. I have been watching my resources and I have not seen anything taxed to cause this. Could this be an issue with the OS? Could it be corrupted somehow? Is it possible to reinstall the OS without losing the data? Any help would be appreciated.

I would recommend it, actually. You had Secure Boot enabled during the install, which would have setup MOK.
So, reinstalling with Secure Boot Disabled may do a lot to help.:

You will need to back up personal files and data - I just compress them to a USB stick as I find it the easiest way and I do this regularly, so even if I have a total of gigs of data, I only ever back up a few megs (or kilos) at a time.
Otherwise, you can use Back-Ups to just back up your HOME DIRECTORY to a safe location, then follow the instructions to reinstall your preferred custom software above.
@Ultrabenosaurus gave you excellent tips and advice but one thing I see missing in this thread is a list of

sudo lshw -C network

to identify your to identify your device so you can check the drivers or Radio Module so modprobe can probe it .