Error after partial update

Hello! I tried to update and I got something like partial update and I did. After that i turned it off and when i turned it on today, it goes to this screen:

Before this screen, I normally go through the zorin boot screen.

I've tried running boot repair via live usb and it still doesn't work. Does anyone have any idea what happened? I can't reinstall the system right now, so I'd like to recover.

When machine boots, choose advanced options and choose recovery item. See if enable networking throws any errors as that screen is referring to your realtek network device not initialising at boot time. If no errors, drop to Root Terminal from recovery menu and enter:

sudo apt-get update --fix missing

then

sudo apt-get install -f

to force repair of broken packages.

Afterwards don't choose resume, turn off the machine then turn it on again.

Hello, The partial upgrade have more likely installed a new kernel, but not completely (without the linux-headers).

From the grub menu, go to the second line 'advance options for Zorin' and it will propose you to boot from a previous kernel, select the version# inferior to the latest# you see on top line.
It should boot normally with all your functionalities.
once booted in a terminal
dpkg -l | grep -Ei "linux-(ge|h|i|lo|mo|o|si|t)"

will list all kernel's components installed.
you will need then to remove the newest [only] incomplete kernel components

sudo apt-get remove [packages names] --purge