Error: '/boot/grub/i386-pc/normal. mod' not found

frist the electric was turn off while my laptop was on.
and when i try to open it i got error about "hd0" something like that. i try using "boot repair" from zorin iso but now i got

Firstly, PXE is network boot so you may want to play with boot sequence in your BIOS / (U)EFI control panel if you don't regularly boot from a network source - it's an unnecessary delay in turning on your computer if you don't use it.

As for the grub error, also very interesting. i386 is for non-EFI 32bit computers, and Zorin's Ubuntu base doesn't officially support 32bit machines any more. If your grub worked preivously then you shouldn't have a similarly cursed device as I do, running 32bit (U)EFI despite having a 64bit CPU. I'm guessing that the power cut either corrupted your HDD or at least the parts of it needed for (U)EFI or grub.

You will need to manually boot into Zorin and reinstall grub, I believe.

Boot Into Zorin

  1. Use Super Grub2 Disk from a USB stick
    • (I recommend flashing Ventoy and keeping some handy tools to hand, like GParted and CloneZilla and a couple of linux ISOs as well as SG2D)
  2. Manually boot from the grub rescue shell

(if neither work to boot into your installed Zorin OS, it may be very corrupted or damaged from the power failure, so use a live environment to try and mount the partition to rescue important data before reinstalling Zorin completely, unless someone more knowledgeable and skilled than I am has a better option)

Repair / Reinstall Grub

Once in Zorin, not from the live ISO, open a terminal and run these commands one-by-one:

sudo apt install os-prober efibootmgr
sudo grub-mkconfig -o /boot/grub/grub.cfg
sudo update-grub

Alternatively, if the above didn't work after rebooting, get back into Zorin again and then try:

sudo grub-install /dev/sdX  # where X is the drive Zorin is installed on, e.g. sda, sdb
sudo update-grub

I can't believe you to be honest. It's just a file didn't exist and just from that I should reinstall the whole system., :sweat_smile::smiling_face_with_tear:

If you have fixed it via some other method, it would be kind of you to post the full details of what was wrong and your solution here for others in the future.

Okay.

A file that shouldn't really be used in the first place, unless you've already gone through the trouble of configuring a 32bit grub separately from your Zorin install, which only supports 64bit, in which case I doubt you'd be asking for help here.

Maybe, maybe not. Your original post has very little information to work from, so I have no idea what the actual problem is and tried to give you a thorough response. Sorry if you don't like that.

If you read my whole reply, my actual suggestion is to try repairing or reinstalling grub, not the whole of Zorin. It should be possible to fix or reinstall a broken bootloader, and I have suggested some ways to do so.

However, if a working grub (such as Super Grub2 Disk, a tool specifically designed to help people boot into any installed OS when they are having bootloader issues) cannot boot you into Zorin, then the OS itself may have been corrupted by your power failure. This can happen if the power is cut while the OS is writing to system files, leaving them in an unfinished state and thus not being "correct" when trying to boot back up when power is restored.

If that is the case, it may be possible to fix, it may not; but fixing such a broken OS is very situational and depends entirely what was corrupted, your skill level to find and fix the corrupted parts of the system, and a notable trade off between the time and effort you're willing to spend in trying to fix it (not guaranteed) versus getting important data off and then reinstalling.

1 Like

i don't know what you mean my laptop 64bit

its not about something i just surprised from your reply
but at the same time you are right . it will be waste if i try to fix something broken already

i just install slax linux in ventoy usb and open the file manger and move the files to another partition