Error communicating to TPM chip

My computer was working fine until today. However, now when I start my computer I get an error message comprising 6 lines of "ima: Error Communicating to TPM Chip". Then there is a line starting with " BusyBox v1.27.2 etc). Finally I get " (initramf s). This is where the computer stops. Please advise how i can solve the problem.

You may need to enable TPM in your BIOS EFI settings of your motherboard.
The way to do this varies by manufacturer.

can you try to disable tpm in BIOS??

@dnob Any success with your issue? Updating helps others in the future...

1 Like

I recently upgraded my BIOS as I had been suffering from intermittent restarts whilst browsing. Having been working from home since March 2020 until I retired in August 2021 I had forgotten to check for updates. I have an Asus PRIME X470-PRO and they released an update to allow Windows 11 to be installed without the need for TPM (I should hasten to add that I did not install this update, just the one before it and the one after it as I never intend running Windows 11 (or 10 again) ever, period. Check your motherboard manufacturer's website for any updates.

It has solved the problem the first time I changed the BIOS as suggested but the problem is recuring. I also keep getting the BusyBox, etc problem. The bottom line is that the problem has not been solved. I am not quite sure, but I recall that the problem has appeared after the latest system update.

Please include when posting your system specs as this helps the Mods and others when assisting you in a resolution to your problem

System specs:

CPU
GPU
RAM
HD
ZORIN OS (i.e. Core Lite Pro )
Make of Computer
Model

OK. Will find out all the details and include in the future. What I know at the moment is that I am using a HP, Elitebook 8440p and Zorin Lite.

Interesting post on Linux Mint forum here:
https://forums.linuxmint.com/viewtopic.php?t=323353

and this one on the BusyBox error:

https://forums.linuxmint.com/viewtopic.php?t=310055

1 Like

Thanks for these. Whilst the fixes work when I apply them, they do not seem to be "permanent". What I mean is that I have to repair the error (BusyBox) every time I start the computer. This apparently also fixed the TPM chip issue.