Error detected while processing /var/lib/vim/addons/plugin/02tlib.vim

When I upgraded from the 16 core version of Zorin to 17 core, and when I opened Vim on Zorin 16 there was no plugin error like that, and when I upgraded to Zorin 17 why did the Vim plugin error? So I looked for references on several forums but it still hasn't fixed it.

Error detected while processing /var/lib/vim/addons/plugin/02tlib.vim:
line 77: E1208: -complete used without allowing argumentsPress ENTER or type command to continue

and when I tried to delete vim from the zorin os jammy repository there was a package error

The following packages were automatically installed and are no longer required:
  editorconfig erlang-base erlang-crypto erlang-syntax-tools flake8 liblua5.2-0 libpython2-stdlib libpython2.7-minimal libpython2.7-stdlib pyflakes pyflakes3 python-pkg-resources python-pyflakes python2 python2-minimal python2.7
  python2.7-minimal python3-autopep8 python3-bottle python3-flake8 python3-frozendict python3-jedi python3-mccabe python3-parso python3-pep8 python3-pycodestyle python3-pyflakes python3-requests-futures python3-waitress ycmd
Use 'sudo apt autoremove' to remove them.
The following packages will be REMOVED:
  vim-addon-manager* vim-addon-mw-utils* vim-airline* vim-airline-themes* vim-athena* vim-autopep8* vim-bitbake* vim-command-t* vim-common* vim-ctrlp* vim-doc* vim-editorconfig* vim-fugitive* vim-gtk* vim-gtk3* vim-gui-common*
  vim-haproxy* vim-icinga2* vim-julia* vim-khuno* vim-lastplace* vim-latexsuite* vim-ledger* vim-migemo* vim-nox* vim-pathogen* vim-puppet* vim-python-jedi* vim-rails* vim-runtime* vim-scripts* vim-snipmate* vim-snippets* vim-syntastic*
  vim-syntax-gtk* vim-tabular* vim-textobj-user* vim-tiny* vim-tjp* vim-tlib* vim-ultisnips* vim-vimerl* vim-vimerl-syntax* vim-voom* vim-youcompleteme* zorin-os-minimal*
0 upgraded, 0 newly installed, 46 to remove and 2 not upgraded.
After this operation, 80,1 MB disk space will be freed.
Do you want to continue? [Y/n] Y
(Reading database ... 503728 files and directories currently installed.)
Removing vim-ultisnips (3.1-3.1) ...
Info: removing broken addon 'ultisnips' from /var/lib/vim/addons
/usr/lib/ruby/vendor_ruby/vim/addon_manager/addon/legacy.rb:104:in `delete': Is a directory @ apply2files - /var/lib/vim/addons/pythonx/UltiSnips (Errno::EISDIR)
	from /usr/lib/ruby/vendor_ruby/vim/addon_manager/addon/legacy.rb:104:in `rmdirs'
	from /usr/lib/ruby/vendor_ruby/vim/addon_manager/addon/legacy.rb:93:in `block in remove'
	from /usr/lib/ruby/3.0.0/set.rb:344:in `each_key'
	from /usr/lib/ruby/3.0.0/set.rb:344:in `each'
	from /usr/lib/ruby/vendor_ruby/vim/addon_manager/addon/legacy.rb:93:in `remove'
	from /usr/lib/ruby/vendor_ruby/vim/addon_manager.rb:55:in `block in remove'
	from /usr/lib/ruby/vendor_ruby/vim/addon_manager.rb:54:in `each'
	from /usr/lib/ruby/vendor_ruby/vim/addon_manager.rb:54:in `remove'
	from /usr/bin/vim-addon-manager:282:in `<main>'
dpkg: error processing package vim-ultisnips (--remove):
 installed vim-ultisnips package pre-removal script subprocess returned error exit status 1
dpkg: too many errors, stopping
Errors were encountered while processing:
Processing was halted because there were too many errors.
E: Sub-process /usr/bin/dpkg returned an error code (1)

So can you help me here?, because this is very annoying when using Vim, and I write code with Vim

At any point, did you check specifying the path to your VIM Plugin?

Have you checked your sources?
Check sources

Manage sources after upgrade

Once all sources are ensured:

sudo apt update && sudo apt dist-upgrade

Check here for information on a VIM plugin patch:

my repo source true jammy

but I haven't tried this

I'll try first, wait

thank you very much, I have tried this one
and finally solved

command! -nargs=0 -complete=command TBrowseScriptnames call tlib#cmd#TBrowseScriptnames()

change to ? in line 77 plugin 02tlib.vim

command! -nargs=? -complete=command TBrowseScriptnames call tlib#cmd#TBrowseScriptnames()

referensi commmit