Error message using balenaEtcher

Kind of a newbie to Linux OS, I have Zorin 17 Pro installed on my laptop, and I installed a program called BalenaEtcher to make a bootable .iso usb drive of Linux Mint latest version for a friend. I launched BalenaEtcher came up with no problems, but when I picked the Linux Mint .iso to flash I got this error:

Screenshot from 2024-06-20 05-11-07

How do I fix this error.

Welcome to this forum Macbookzorin1. The short answer is don't use Balena. Many people have reported that Balena has killed their usb thumbdrives.

The best way I have found to make a bootable .iso is to go to your Zorin menu and find the Discs program. Plug in your usb stick and then open Disks. Select your thumbdrive from the list of drives. At the top right of the disks program you will see 3 small dots. Click on the dots and a menu will open. Select restore disk image. Then go to your downloaded .iso file and select it. Then let disks "restore" your .iso file to the thumbdrive. Just be sure that you have selected your thumbdrive before you do that. You dont' want to overwrite your operating system.
I have used this method many times and it has always given me a good .iso bootable thumbdrive.

4 Likes

Interesting, we use Balena in a professional environment to produce security test bootable distros. We have done 1000s of these and had maybe 2 thumb drives have failed, and they had been rewritten multiple times. This is all using an Ubuntu 22.04 system.

I will say that we install via deb file as the appimage isn't that reliable.

Welcome to the Forum!

Do You use the AppImage or the .deb Version of Etcher? Did You checked if You have a Problem with other Tools like Popsicle or Fedora Media Writer? Have You controled the Checksum of Your Mint ISO?

Good to know. Luckily at that time I just extracted the .iso with WinRAR from Windows 7 Starter where I installed Zorin OS Core 16.3 for my current laptop and had no problems on installing it. I neither used balenaEtcher nor backed up my USB stick content and I anyway can use Zorin OS Core and didn't even lose anything from my USB stick as warned on Create a bootable USB Install Drive.

When You use Windows Rufus is a good Tool to create a bootable Stick.

1 Like

Interesting, thanks :handshake:, added to my bookmarks :star::slightly_smiling_face:. The USB stick there looks the same I have :smile:.
immagine
Just to know, I see a scrollbar vertically in the middle of Rufus page, do you see it, too?

1 Like

Don't use Balena.
Use Ventoy. It is fast and easy.

1 Like

The only issue I have had with Ventoy might be down to corrupt sectors on the thumb drive or it just doesn't like certain .isos. I gave had issues getting 32-bit isos to run and more recently with 64-bit PCLinuxOS, Nitrux and Mint all coming up with a loop error, looking for a CD (yes I know images are of DVD size but Linux kernel still refers to CD's even if burned to DVD), so I have had to resort to DVD. Also use GtkHash to check the checksum of the downloaded .iso, it should be in the repos, install it via Synaptic Package Manager.

Could You show a Picture?

1 Like

I want to ask one thing.
Can i use Zorin OS ISO with Ventoy?
Without any errors?

Hasn't been an issue for me, but not tried with latest release.

Hmm ... interesting. No, I don't have that. You could change the Language in the upper right Corner to Your local Lagauge and look if it still appears like that.

Another Thing: Type the Adress manually in the Browser: rufus.ie

1 Like

Doesn't change in any case :person_shrugging:. Well, never mind, it's not our business, the page works anyway and I just asked, I'm not going to report such thing either.

1 Like

Thanks I will try that.

I tried it and it worked perfectly, now if I could just remember this, its not like i burn .iso files everyday.