Error message

I have just installed TypeApp Mail, when I start it I get this error message as shown in the picture. Someone who knows what I should do

This looks like the TypeApp mail application is installed as a Snap Package rather than the standard APT packaging.

Looking at their page, they appear to only offer as Snaps (A limited way of doing things...):

Their proposed solution is

sudo apt install snapd

However, Zorin OS comes with snapd already installed.
It may be that they require snapcraft, as well.

snap install snapcraft --classic

Yes but what I don't understand, I had it installed on the other ssd drive with no problems and I don't remember installing snapcraft, I usually just use zorin software

Are you on Zorin OS 17?
Was the other ssd on Zorin OS 16 or Zorin OS 17?

both were zorin os 17 pro

Have you tried installing snapcraft as outlined above?

Yes, it doesn't change anything

You install Blue Mail using wget. TypeApp is built on Blue Mail so maybe

At the top of this page is a download offer for "Latest / stable"

Does that action work for you?

No, I've tried it and Zorin software and Snap

What is the terminal output for:

sudo snap install typeapp-mail

typeapp-mail 3.21.208 from TypeApp LLC (typeapp) installed

Does the app launch?

no get the same error

I have tried multiple net searches on this issue. I can find very little.
I am not sure if this is a Snap issue or if it relates to Zorin OS.

Zorin OS 17 no longer includes Snapcraft. Personally, this is a change that I agree with because it is supposed to allow user choice and control (users can choose to use Snaps), but removes the forceful nature of Snaps. I cannot see how that would result in your error, but the possibility that the two are related cannot be ignored.

Yes, I don't know, I'm not that smart about linux, but Snapcraft is part of Zorin Software.
I wish I had made a backup of my ssd drive before it crashed.
I have to be satisfied with BlueMail and the irritating splash screen.
Thank you for all you have done

Basic troubleshooting... You might try

sudo snap install core --edge --classic

sudo snap refresh

Ensure snapd is running:

sudo systemctl status snapd

Check connectivity to Snap Store:

snap info core

Specific to the app:

sudo snap remove io.snapcraft.typeapp-mail

sudo snap install io.snapcraft.typeapp-mail

Zorin software includes Flatpaks, Snaps, AppImages, and Debian/Ubuntu packages. Some programs have multiple versions based on the different formats.

Usually, Flatpaks and/or Snaps are newer versions of the software which is their main advantage. Traditional packages are locked to the version of the operating system. Zorin does a good job bypassing this limitation by offering their own repositories to many Ubuntu/Debian applications that are back-ported.

So, despite being locked to the Ubuntu 22.04 LTS base for ZOS 17, you still get some newer software via their PPAs. But for everything else, you have Snaps and Flatpaks which have their own idiosyncrasies.

Some people have very strong opinions on this issue. I just like that Zorin has it all available so you can find what you need without a convoluted effort to get some needed software installed. Big KUDOS to Zorin for that.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.