Error: Must load Kernel first

Hello everyone, another story in my life. In the past two months I have installed, uninstalled, and installed over all the following, Linux Mint,MX Linux, an arch derivative, fedora, and something else (possibly another, I don't remember it 's all running together", But I have had the same problem every single time, I run the live cd, and everything is perfect, then I install the OS, then when I reboot/boot, I get an error of Must load kernel first, or I get a screen with a cli that says "Minimal bash line editing is supported for the first word tab lit possible comment completions......." and a lot more stuff. Then for the first time tonight, I got a "locked-Nvram Detected"". At this point I think it's probably my pc, so I'm going to go to Dell support and check with them, just see if they know anything. But I thought I would leave it here too, just in case someone had ran into this. I have ran the Boot Repair that's in the live cd, no help, as i said, I have tried reinstalling,downloading iso's from different servers, and searched every forum i could fine, except this one, and i'm here now. I've ran all kinds of test's, done all kinds of cli trying to locate the problem, and every thing comes back good, soft and hardware. I'm stumped.

Oh cool, you have a BOOT REPAIR ready to go, good, cause I think your going to need that. Does that BOOT REPAIR not have an option to download and install the 5.11.38 Linux kernel? I've never used it personally. I'm afraid I can't be much help in this area, you will need a higher level of support who has the experience with this issue, and that would be @Aravisian

No actually I was rather suprised just how simple the program is. When it load up, you have two buttons, one that says "Repair", and that repairs any and everything that might be wrong. The other is the option to upload a diagnoistic file to pastebin, if you upload, then you are given a web address, that you can share on forums, so others can see what's going on.

If you have a copy of the live installer, it has the boot repair on it. Most of the other distro's I've played with had it on the installed version, I just haven't looked that far into Zorin yet, but I'm sure it's here.

Yes, I second the idea of communicating with Dell.

Dell computers are also affected by a kernel bug that did affect Zorin OS 16. Though repaired in the release r1, always take a bug repair with a pinch of salt.
You may try updating (flashing) the Dell Firmware or BIOS and you can try using the parameter --no-nvramduring installation.
Some users navigated this problem by using rEFInd with installation of Zorin OS.

Thank you so much for the information. Just one more thing if you don't mind. Help a newbie out, what exactly are the full commands on the two you listed, and where and when do I put them in? Or better yet if there is a website I can find the information that would be great, that way I can refer back to it, anytime I come across a command I don't know.

This Query / Answer links several - it MAY help.
https://itectec.com/ubuntu/ubuntu-how-to-get-grub-efi-amd64-signed-to-not-automatically-overwrite-nvram-on-update/

You can find rEFInd here:
https://www.rodsbooks.com/refind/

Thanks so miuch

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Marked solution. 255