Error when installing new security update

I have a ROG Zephyrus G14 laptop with Zorin OS lite with full-disk encryption. Today I got a notification on a new security update (as I remember, only the security update), so I hit update as normal, hit restart when done, went to have lunch, cameback, entered the password for encryption and got the screen above. Tried restarting a few times but still the same error so I boot into my USB and luckily Timeshift saved it.
I don't know what caused the issue but wonder if anyone else has the same problem with me or it's just me. Others who don't have Timeshift enabled shouldn't update in the meantime.



Can you please relay the clearest details you can recall about the notification on a Security Update? Was it the Updater Software? Or was it a notification received prior to reaching the desktop?
Do you recall any package details? Did it relate to Mok-utils?
Do you have Secure Boot enabled?

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.