Error when try install IntelliJ IDEA Community [Zorin Lite 16.2]

Hi, it's my first post so my apologyze if im wrong.

Im new here on this world about Linux and Zorin OS.

I want install IntelliJ IDEA Community from Software Store but i get the next error

Cannot install <<Freedesktop SDK>>:
Error pulling from repo: GPG verification enabled, but no signatures found
(use gpg-verify=false in remote config to disable)

So how i said im new so i don't wanna do anything that causes more errors.

If someone can help me I'll be so grateful

Regards my dear friends

Did you add a repo that is unsigned ?

Try sudo flatpak repair --user or flatpak repair --user and flatpak update

How i should do that? ...

Btw i execute the commands that you said ... This was the response

dmt@dmt-pc:~$ sudo flatpak repair --user
[sudo] contrase√Īa para dmt:      
error: Refusing to operate under sudo with --user. Omit sudo to operate on the user installation, or use a root shell to operate on the root user's installation.
dmt@dmt-pc:~$ flatpak repair --user
Working on the user installation at /home/dmt/.local/share/flatpak
Comprobando remotos...
Podando objetos
dmt@dmt-pc:~$ flatpak update
Buscando actualizaciones…

Nada que hacer.
dmt@dmt-pc:~$ 

After excute -> flatpack update
the translate for you is -> Searching updates... nothing to do

Try

flatpak remote-modify --no-gpg-verify flathub

Install the packages and when done undo the modify

flatpak remote-modify --gpg-verify flathub

Well i excute

flatpak remote-modify --no-gpg-verify flathub

Try to install IntelliJ IDEA and the new response are

Cannot install <<Freedesktop SDK>>:
Can't pull from untrusted non-gpg verified remote

@dmt, does it not have a .deb package to install from ? Tried the website version Install IntelliJ IDEA | IntelliJ IDEA

2 Likes

Oks @Michel i will try now

In some minutes i send a report here

thanks for your time dude! :smiley:

1 Like

It's work from official page ...

Thanks thanks thanks ...

1 Like

Glad that worked, have fun with it :smiley:

2 Likes