Error when updating to Kernel 6.2

I just tried to run kernel 6.2
When I did so, I got some error messages.

Any idea what they mean and how to fix it?

mainline 1.4.9
install 6.2 
Downloading 6.2
Installing 6.2                                                        
Vormals nicht ausgewähltes Paket linux-image-unsigned-6.2.0-060200-generic wird gewählt.
(Lese Datenbank ... 279462 Dateien und Verzeichnisse sind derzeit installiert.)
Vorbereitung zum Entpacken von .../linux-image-unsigned-6.2.0-060200-generic_6.2.0-060200.202302191831_amd64.deb ...
Entpacken von linux-image-unsigned-6.2.0-060200-generic (6.2.0-060200.202302191831) ...
Vormals nicht ausgewähltes Paket linux-headers-6.2.0-060200-generic wird gewählt.
Vorbereitung zum Entpacken von .../linux-headers-6.2.0-060200-generic_6.2.0-060200.202302191831_amd64.deb ...
Entpacken von linux-headers-6.2.0-060200-generic (6.2.0-060200.202302191831) ...
Vorbereitung zum Entpacken von .../linux-modules-6.2.0-060200-generic_6.2.0-060200.202302191831_amd64.deb ...
Entpacken von linux-modules-6.2.0-060200-generic (6.2.0-060200.202302191831) ...
Vorbereitung zum Entpacken von .../linux-headers-6.2.0-060200_6.2.0-060200.202302191831_all.deb ...
Entpacken von linux-headers-6.2.0-060200 (6.2.0-060200.202302191831) ...
dpkg: Abhängigkeitsprobleme verhindern Konfiguration von linux-headers-6.2.0-060200-generic:
 linux-headers-6.2.0-060200-generic hängt ab von libc6 (>= 2.34); aber:
  Version von libc6:amd64 auf dem System ist 2.31-0ubuntu9.12.
 linux-headers-6.2.0-060200-generic hängt ab von libssl3 (>= 3.0.0); aber:
  Paket libssl3 ist nicht installiert.

dpkg: Fehler beim Bearbeiten des Paketes linux-headers-6.2.0-060200-generic (--install):
 Abhängigkeitsprobleme - verbleibt unkonfiguriert
linux-modules-6.2.0-060200-generic (6.2.0-060200.202302191831) wird eingerichtet ...
linux-headers-6.2.0-060200 (6.2.0-060200.202302191831) wird eingerichtet ...
linux-image-unsigned-6.2.0-060200-generic (6.2.0-060200.202302191831) wird eingerichtet ...
I: /boot/vmlinuz.old is now a symlink to vmlinuz-5.15.0-88-generic
I: /boot/initrd.img.old is now a symlink to initrd.img-5.15.0-88-generic
I: /boot/vmlinuz is now a symlink to vmlinuz-6.2.0-060200-generic
I: /boot/initrd.img is now a symlink to initrd.img-6.2.0-060200-generic
Trigger für linux-image-unsigned-6.2.0-060200-generic (6.2.0-060200.202302191831) werden verarbeitet ...
/etc/kernel/postinst.d/initramfs-tools:
update-initramfs: Generating /boot/initrd.img-6.2.0-060200-generic
W: Possible missing firmware /lib/firmware/i915/dg1_huc.bin for module i915
W: Possible missing firmware /lib/firmware/i915/tgl_huc.bin for module i915
W: Possible missing firmware /lib/firmware/i915/tgl_huc.bin for module i915
W: Possible missing firmware /lib/firmware/i915/dg2_huc_gsc.bin for module i915
W: Possible missing firmware /lib/firmware/i915/skl_guc_70.1.1.bin for module i915
W: Possible missing firmware /lib/firmware/i915/bxt_guc_70.1.1.bin for module i915
W: Possible missing firmware /lib/firmware/i915/kbl_guc_70.1.1.bin for module i915
W: Possible missing firmware /lib/firmware/i915/glk_guc_70.1.1.bin for module i915
W: Possible missing firmware /lib/firmware/i915/kbl_guc_70.1.1.bin for module i915
W: Possible missing firmware /lib/firmware/i915/kbl_guc_70.1.1.bin for module i915
W: Possible missing firmware /lib/firmware/i915/cml_guc_70.1.1.bin for module i915
W: Possible missing firmware /lib/firmware/i915/icl_guc_70.1.1.bin for module i915
W: Possible missing firmware /lib/firmware/i915/ehl_guc_70.1.1.bin for module i915
W: Possible missing firmware /lib/firmware/i915/ehl_guc_70.1.1.bin for module i915
W: Possible missing firmware /lib/firmware/i915/tgl_guc_70.1.1.bin for module i915
W: Possible missing firmware /lib/firmware/i915/tgl_guc_70.1.1.bin for module i915
W: Possible missing firmware /lib/firmware/i915/dg1_guc_70.bin for module i915
W: Possible missing firmware /lib/firmware/i915/tgl_guc_69.0.3.bin for module i915
W: Possible missing firmware /lib/firmware/i915/tgl_guc_70.1.1.bin for module i915
W: Possible missing firmware /lib/firmware/i915/tgl_guc_70.bin for module i915
W: Possible missing firmware /lib/firmware/i915/adlp_guc_69.0.3.bin for module i915
W: Possible missing firmware /lib/firmware/i915/adlp_guc_70.1.1.bin for module i915
W: Possible missing firmware /lib/firmware/i915/adlp_guc_70.bin for module i915
W: Possible missing firmware /lib/firmware/i915/dg2_guc_70.bin for module i915
W: Possible missing firmware /lib/firmware/i915/adlp_dmc_ver2_16.bin for module i915
W: Possible missing firmware /lib/firmware/i915/dg2_dmc_ver2_08.bin for module i915
/etc/kernel/postinst.d/zz-update-grub:
Quelldatei `/etc/default/grub'
Quelldatei `/etc/default/grub.d/init-select.cfg'
GRUB-Konfigurationsdatei wird erstellt …
Thema gefunden: /usr/share/grub/themes/zorin/theme.txt
Linux-Abbild gefunden: /boot/vmlinuz-6.2.0-060200-generic
initrd-Abbild gefunden: /boot/initrd.img-6.2.0-060200-generic
Linux-Abbild gefunden: /boot/vmlinuz-5.15.0-88-generic
initrd-Abbild gefunden: /boot/initrd.img-5.15.0-88-generic
Linux-Abbild gefunden: /boot/vmlinuz-5.15.0-87-generic
initrd-Abbild gefunden: /boot/initrd.img-5.15.0-87-generic
Startmenüeintrag für UEFI-Firmware-Einstellungen wird hinzugefügt
abgeschlossen
Fehler traten auf beim Bearbeiten von:
 linux-headers-6.2.0-060200-generic
mainline: done

You are getting a libc6 dependency error due to Canonical (Ubuntu) deciding to set a higher dependency on the later kernels (I won't get into the politics of why...)
This is easily fixed.
In terminal run:

sudo apt --fix-broken install

sudo apt clean && sudo apt autoremove

Now, install kernel 6.2 using the TuxInvader repository which is corrected for libc6:

sudo add-apt-repository ppa:tuxinvader/lts-mainline

And install the 6.2 Kernel:

sudo apt update && sudo apt install linux-generic-6.02

1 Like

Thank you, it seems to work!

1 Like