Error while trying to upgrade from 16.3 to 17

Hi folks, when I launch the the Zorin Updater, I see the following error.

Manual update via

sudo apt update && sudo apt upgrade


0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

What am I missing? Thx

Do you have 3rd party sources in your sourcelist? If so, disable them and try again.

Thx Storm.

I don't have any. I re-ran apt upgrade from the command line as well as run the Zorin upgrader, still no luck

A more descriptive error message would help.
I wonder if it is something quite simple like too much traffic on the servers since Zorin OS 17.1 Lite was just released.

In which case, trying it again in a day or so may clear it up...

When I see this on Your Picture right You have as Download Source US-Server (there stand us.archive.ubuntu ...)?

You could try to change in Sotware & Updates in the first Tab to set the Server to Main Server and then try it again.

1 Like

@Aravisian : What logs are you looking for? I can look into that if I run into it next time around.

@Ponce-De-Leon: That didn't help.

I bit the bullet and fresh installed 17.1. Had backups for my data. Thx

Sorry, I was not very clear in my above statement. I meant that the application itself gives an error message that is very vague:
"An error occurred. Please try again later."

It actually is quite difficult to program an application to relay directed errors that can report specific causes. The developer must anticipate a lot. Even then, a generic message still will apply for anything the dev did not anticipate.

So the error displayed by the app really gives us nothing to work with.

I almost suggested this, too. :stuck_out_tongue: