Error with WINE on Zorin OS 16.3

But I'm having strange errors
IDK what's going on here

Have you checked the link in this post?

Bruh I'm on new OS now Zorin Core I have no wine and I didn't even try Roblox

The link references Roblox Studio which is what you said you are using.

You must be informative with your posts and keep the threads updated on what you have tried and what you are doing. Changes that you make can affect how we respond when we are responding to what information you previously supplied.

I tried it with Roblox studio But actually I need wine for other things like kaspersky and lots of other programs which not supporting linux

Please see this post for installing Wine:

I tried this solution but

You need to please remove that defunct Repository for sysvinit-backlight as previously discussed. Also, please address the Brave Browser warning by running this in terminal;

echo "deb [arch=amd64 signed-by=/usr/share/keyrings/brave-browser-archive-keyring.gpg] stable main"|sudo tee /etc/apt/sources.list.d/brave-browser-release.list

That said - perhaps wine staging is not supported for 20.04...
Please test running

sudo apt install --install-recommends winehq-stable

Lastly - you already had i386 arch added, which the first command was to determine. Then you ran the command a second time to add it.
Please only run necessary commands in the terminal. Guessing or just blindly trusting terminal commands from the internet can give you grief.

You are on Focal, but you have a Jammy Wine Repository added.
From the post I linked you to:

I can't find any


Please post the output of

ls /etc/apt/sources.list.d

yeah here I can see that jammy wine

To elevate your file manager to Root:

sudo -i


In the left pane, click on "other locations". In the right pane, click on "computer"
Now double click on etc, then apt, default and finally, sources.list.d
Be sure to double clik on the folder named sources.list.d, not the file named sources.list
Delete the nrbrtx-ubuntu sysvinit-backlight - both of them.
Delete both the wine Jammy and Kinetic.
Once done, close out the file manager and the terminal.

Launch new terminal and try

sudo apt update

sudo apt install --install-recommends winehq-staging

thanks mate I have wine now but I got this error when I wanted to open wine --control

Can you please check on the WineHQ Forums for more specific Wine help?

Certainly, we will do our best here to help you as well.

1 Like

@Inzingor Hello again mate I used vinegar as you said, the point now that roblox working and opening without any problems but I need roblox studio and when I'm trying it I'm getting this error

Failed to create OpenGL context for format QSurfaceFormat(version 2.0, options QFlags QSurfaceFormat::FormatOption(), depthBufferSize 24, redBufferSize -1, greenBufferSize -1, blueBufferSize -1, alphaBufferSize 8, stencilBufferSize 8, samples -1, swapBehavior QSurfaceFormat::DoubleBuffer, swapInterval 1, colorSpace QSurfaceFormat::DefaultColorSpace, profile QSurfaceFormat::NoProfile).
This is most likely caused by not having the necessary graphics drivers installed.
Install a driver providing OpenGL 2.0 or higher, or, if this is not possible, make sure the ANGLE Open GL ES 2.0 emulation libraries (libEGL.dll,
libGLESV2.dll and d3dcompiler_*.dll) are available in the application executable's directory or in a location listed in PATH.

@Aravisian @337harvey @Inzingor and also I found the 3 mentioned libraries already exist in the folder of the vinegar

It does mention that they must be in the correct path. Have you checked the WineHQ forums on this issue?