Ethernet intermittently stops working

Hello I'm having the exact same issue. My Ethernet worked then stopped. Then two days ago I booted the machine and it was working. Now it's out again. It was fine at first install and has worked perfectly for months till recently. So I'm pretty sure an update killed the connection. Wi-Fi still works. I can't understand why Ethernet was working but was intermittent.

TIA for any help provided.

info on hardware.
carl@carlp7:~$ sudo lshw -C network
[sudo] password for carl:
description: Ethernet interface
product: AR8161 Gigabit Ethernet
vendor: Qualcomm Atheros
physical id: 0
bus info: pci@0000:01:00.0
logical name: enp1s0
version: 08
serial: 78:e3:b5:bb:9a:10
size: 1Gbit/s
capacity: 1Gbit/s
width: 64 bits
clock: 33MHz
capabilities: pm pciexpress msi msix bus_master cap_list ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd 1000bt-fd autonegotiation
configuration: autonegotiation=on broadcast=yes driver=alx driverversion=5.15.0-82-generic duplex=full latency=0 link=yes multicast=yes port=twisted pair speed=1Gbit/s
resources: irq:19 memory:fea00000-fea3ffff ioport:e000(size=128)
description: Wireless interface
product: RT5390R 802.11bgn PCIe Wireless Network Adapter
vendor: Ralink corp.
physical id: 0
bus info: pci@0000:04:00.0
logical name: wlp4s0
version: 00
serial: b8:76:3f:36:98:7e
width: 32 bits
clock: 33MHz
capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
configuration: broadcast=yes driver=rt2800pci driverversion=5.15.0-82-generic firmware=0.40 ip= latency=0 link=yes multicast=yes wireless=IEEE 802.11
resources: irq:19 memory:fe900000-fe90ffff

Gday @CwMont ,
First, can i ask you to update your profile to indicate the Zorin OS Edition your using please.

Is the BIOS firmware/drivers up to date?
If not please update.

Have tried refreshing the main Gateway/Routers?

The output of lshw-C multimedia looks good.

As this has happened before, do you know what the pc repair shop had done to the pc, that may help us here?

Is the dual boot?

Are you dual booting with Windows OS?
Is Secure Boot enabled in your BIOS /EFI Settings?

Zorin 16.3 PRO

My PC is an older HP P7-1534 AMD A8-5500 16 GIG RAM all BIOS and firmware up to date. System is NOT dual boot and was a fresh install of 16 PRO on a new Samsung SSD. Secure boot is currently disabled. It's been a while since I did the install but I'm pretty sure I disabled it prior to install.

The system was working fine with both Ethernet and wi-fi. Spectrum Cable modem with separate wi-fi router. Both have been rebooted in attempts to solve this issue without success.

The machine has been working perfectly since the install months ago. Only within the past two to three weeks has this issue appeared. I thought it might be my hardwired connection but it checks out fine with my Windoze laptop.

Last weekend when I booted up the machine the Ethernet connected right up. The next day it didn't and hasn't since. No repairs done to the machine. However the secondary HDD was replaced by me with an SSD a few months back but the machine worked fine after that.

Since my lshw-C multimedia looks good. I'm at a loss as to what's going on. Also this is my first Linux box so maybe I'm missing something? I still can't help but feel an update of some type caused this.

Any help is appreciated.

1 Like

Can you please boot into the Grub Menu, either by tapping esc or tab at boot.
Select Advanced Options for Zorin and choose to boot Zorin OS on an earlier kernel (perhaps the -56 or -76).
Once booted, test the Ethernet connection.

my choices are
5.15.0-82 generic and generic recovery
5.15.0-79 generic and generic recovery

I tried booting to both versions using the "generic" option and the result is the same. No Ethernet connection.

I do have timeshift installed and did a snapshot on 07/05/2023 the Ethernet connection was working at that time. Do you think I should I try and restore that snapshot?


First, can you relay the terminal output for

sudo dpkg -s linux-modules-extra-$(uname -r) | grep Status

What we are looking for is the linux-modules-extra--5.15.0-82-generic package. If not present, try installing it

sudo apt install linux-modules-extra--5.15.0-82-generic

and booting into and testing the -82 kernel.

arl@carlp7:~$ sudo dpkg -s linux-modules-extra-$(uname -r) | grep Status
[sudo] password for carl:
Status: install ok installed
carl@carlp7:~$ sudo apt install linux-modules-extra--5.15.0-82-generic
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to locate package linux-modules-extra--5.15.0-82-generic
E: Couldn't find any package by glob 'linux-modules-extra--5.15.0-82-generic'

A recent Zorin OS update included the HWE kernel and related packages.

Can you please try:

sudo apt install --reinstall linux-generic linux-generic-hwe-20.04

Reboot to test... Sorry for all this run-around...

Does this laptop have wifi toggle on the f keys or airplane mode?

Have you attempted to toggle airplane mode or the wifi off/on, waiting a few seconds imbetween?

I ask because previous versions of the driver were sometimes installed and started force disabled (toggled off).

Another issue with this driver was the kernels programmed network timing. The driver would work until a major change in the kernel network module. The driver then had to be patched. I wonder if the 6.02 kernel may serve you better for this hardware, as fixes are added to new kernels and firmware. It has happened several times for this driver.

This is an HP tower with wi-fi built in. I don't see a hot key on the KB to turn it on and off.

I did that and rebooted with no success. When I run the uname -r I get this. Don't worry about the run around. After using Windows for decades I'm used to run arounds and frequent re-installs

carl@carlp7:~$ uname -r

*** I ask because previous versions of the driver were sometimes installed and started force disabled (toggled off). ***

I wonder if that's what happened. The wired connection tries to connect, gives an unable to connect message then toggles itself off with any user input.

1 Like

I was just getting to asking about ethernet cable... thanks for bearing me to it.

You can check settings, network tab and ensure it is enabled (wifi too).

When you were in the bios, network/wifi wasn't disabled was it? Not all bios have this option, but some did.

Well it's getting late here so I'll sleep on it and try again tomorrow. Thanks to all for your help. Keep posting and I'll try suggestions again tomorrow.


Cable and connection to router is good works fine with my windows laptop. Zorin shows wired as trying to connect then fails to authenticate and toggles the wired connection off.

Wired details shows the correct hardware MAC address according to PC BIOS but for last used it says NEVER which is surprising as it worked in the past.

Before this reinstall, we're you running Zorin 16.3, or was it an earlier version?

When you're back, might you provide the first or last few lines of this log file: /var/log/apt/history.log

It should be chronologically ordered, i just don't know if it's ascending or descending. You will know when you check the dates, as it may help to see the last 10 to 20 most recent updates.

Since I'm somewhat of a newbie when it comes to Zorin, I'll just post the full lines. Maybe someone will see something I missed.

sudo snap connect ausacity:alsa
sudo snap connect audacity:alsa
sudo apt install ubuntu-restricted-extras
sudo ufw status
sudo ufw enable
sudo ufw status
sudo apt install gufw
sudo dpkg --configure -a
sudo apt install gufw
sudo apt install ubuntu-restricted-extras
sudo apt install gnome-tweak-tool
sh -c 'busybox wget -O /tmp/install && sh /tmp/install'
sh -c 'wget -O /tmp/install && sh /tmp/install'
sh -c 'curl -Lo /tmp/install && sh /tmp/install'
h -c 'busybox wget -O /tmp/install && sh /tmp/install'
sh -c 'busybox wget -O /tmp/install && sh /tmp/install'
sh -c 'busybox wget -O /tmp/install && sh /tmp/install
sh -c 'busybox wget -O /tmp/install && sh /tmp/install'
sudo apt install ubuntu-restricted-extras
sudo su
sudo su apt-get install libdvd-pkg
sudo apt-get install libdvd-pkg
apt-get install vlc browser-pligin-vlc
sudo apt-get install vlc browser-plugin-vld
sudo apt-get install vlc browser-plugin-vlc
sudo add-apt-repository ppa:heyarje/makemkv-beta
sudo a
sudo apt-get update
sudo apt-get install makemkv-bin makemkv-oss
sudo rm -rf /var/lib/apt/lists/*
sudo apt update
sudo apt install gnome-tweaks
sudo add-apt-repository ppa:starlabs/beta
sudo apt update
sudo apt install starlabstheme
sudo apt install gnome-tweak-tool
sudo apt install starlabstheme-gtk starlabstheme-icons starlabstheme-backgrounds starlabstheme-cursor
sudo apt update && sudo apt install arc-theme
sudo apt update; sudo apt upgrade
sudo apt install ubuntu-restricted-extras
sudo apt install vlc gimp gparted 0ad
sudo apt install timeshift
cat /etc/os-release
sudo apt install zorin-os-upgrader
cat /etc/os-release
inxi -Fx
sudo apt install inxi
inxi -Fx
unamer -a
uname -a
sudo lshw -C network
sudo lshw -class network -short
sudo ethool enp1s0
sudo ethtool enp1s0
ip a
1p a s enp1s0
ip a s enp1s0
sudo ethtool enp1s0
nmcli device status
lshw -c network
sudo modprobe -r alx && sudo modprobe alx
inxi -Fxz
sudo apt install inxi
inxi -Fxz
sudo lshw -class network -short
ip a s enp1s0
lspci -knnd ::0200
sudo -E hw-probe -all -upload
lspci -vv | grep Atheros
sudo apt-get install build-essential linux-headers-generic linux-headers-uname -r
sudo modprobe alx
sudo apt-get install linux-backports-modules-cw-3.4-precise-generic
sudo apt -get installlinux-backports-modules-cw-3.6-precise-generic
sudo apt-get install linux-backports-modules-cw-3.4-precise-generic
sudo apt-get install linux-backports-modules-cw-3.6-precise-generic
lspci -nn
lspci -knn | grep -i net A2
sudo lshw -C network
resolvectl flush-caches
sudo service network-manager restart
sudo lshw -C network
sudo modprobe -r e1000e && sudo modprobe e1000e
cat /etc/os-release
sudo dpkg -s linux-modules-extra-$(uname -r) | grep Status
sudo apt install linux-modules-extra--5.15.0-82-generic
sudo apt install --reinstall linux-generic linux-generic-hwe-20.04
uname -r
sudo apt install --reinstall linux-generic linux-generic-hwe-20.04
uname -r

Your firewall is enabled. While this shouldn't be an issue, not having connected to the network already, may cause an issue.

Try sudo ufw disable. I belive that will turn off your firewall for now. This should allow connectivity (we can explore the rules of the firewall later).

Then try ethernet and wifi.

Was the previous version of Zorin also 16.3 or an earlier version (prior to this installation)?

I disabled the firewall and IIRC the original install was 16.0 then I purchased the pro version and received the code to download the 16.3 pro.