Every chromium based browser crashes when I download an image

and when I manually kill the browser and look in my files the file isn't saved in pictures and has this naming scheme ".org.chromium.Chromium.random numbers and letters"

" Every chromium based browser"
Which ones and how were they installed. e.g. Flatpak, snap, apt etc?

1 Like

via the zorin store (flathub)
and I tried every chromium based browser on the store except for vivaldi and edge.
I currently have both opera and base chromium installed and the issue persists

Some people have solved this by disabling hardware acceleration in the settings. I guess there must be something going on there regarding graphic card drivers. Unfortunately, I don't know much about this to recommend anything else, but here's the thread in question:

thanks for the link

Nope still having this issue

Is this :point_down: helpful?
https://www.quora.com/How-can-I-prevent-Chrome-from-crashing-when-downloading-files
To see the replies switch to Answers (7) below the question, reading that topic Quora looks messing up discussions. A user solved this on his phone by changing download location while the best solution is to use a new user account but users there have Windows.

You mentioned that the file isn't saved in the Pictures directory. Can you try the Downloads folder instead?

If this works, then it's most likely an issue with permissions due to the package format that you're using, called flatpak, as @zabadabadoo suggested. Long story short, it's a different software package format with restricted permissions for various reasons such as security, etc.

Another way of confirming whether this is the case is to run this command in a terminal (you can search for "terminal" in the application menu):

flatpak list

If you find your browser(s) listed in here, then it's confirmed they are flatpaks.
Being that the case there are two things you can try:

  1. Uninstall them, and re-install using the native package format for Zorin OS. In the Software Store, under the "Install" button there is a drop-down menu with several options. Whenever it's available, choose "Zorin OS".

    Or, you most likely can also download the same format from the project's website.
    This can vary from one browser to another. For example, Brave can be installed following these instructions.

  2. Alternatively, if you prefer to keep things as they are, there is a program called Flatseal that you can find in the Software Store. What this allows you to do is pick and choose which permissions each flatpak package can have, including accessing certain directories within the file system.

    Take a look at this reply, it seems to be related:

Last night i just backed up my important files and did a clean install.
The issues gone now lol

1 Like