Evolution Dark mode issue

I just got Evolution from flathub and it's great but in dark mode when I see the mail content some of the mails have black background and foreground both. Just to see if it's content issue I installed Thunderbird and I didn't have this issue there.
Any idea how to fix this or should I go with Thunderbird?

If using a Flatpak, you may need to use Flatseal to make themes consistent.
Please see here:

1 Like

Okay so if that's the case why does Thunderbird which I installed using flatpaks only works without any issues?

and I am not saying DarkMode doesn't work, it does work but the mail body contains background and text both in black, which renders the mail body all black.

Also, by the above solution I think I have to run

sudo flatpak override --env=GTK_THEME=THEME-NAME`

whenever I am changing from light to dark mode right?

and BTW, I just did the above steps as well and I could see the theme changing as well I copied ZorinGreen-Light/Dark only just to check if they are getting loaded and they were getting loaded

Just to reiterate I think the theme is getting loaded with from Zorin Apperance setting but the issue is that for some mails, the text color is black and the background is made black because of Zorin's theme and hence I am getting all black.

I checked my gmail on my phone and those mails do get displayed correctly i.e. in dark mode the colors get flipped meaning the text color becomes white and the background becomes dark.

I think specifically for mails we have to do something like that in the current Zorin's theme.

Let me know if that explanation made any sense.

1 Like

Yes, I think I am following you.
In Evolution, using the proper Zorin OS Dark Theme, the Text and the background are both dark.
Let me install Evolution with Flatpak and with APT and test them both...

Yes. It is annoying.

I am unable to replicate this. On the left is the Flatpak Evolution and on the Right is the APT installed Evolution. Both in Zorin Green Dark:

can you share your mail I will send one sample mail which is happening in my case.
BTW I am using Zorin 16.1 Pro

This is the mail that I will send you

There are mails like this as well.

Please be sure no personal details are included in the above screenshots that you need to protect.

This is very odd... did you install Evolution with:

flatpak install flathub org.gnome.Evolution

1 Like

Please be sure no personal details are included in the above screenshots that you need to protect.

I will delete one of the screenshot, I installed Evolution by going to the website and searching for the Evolution then downloading one file which when I ran installed it from Software.

This file org.gnome.Evolution.flatpakref

1 Like

That is the same I used...

I am not sure on this... I do not use Evolution normally and had to install it just to test this.
Perhaps more regular users may weigh in their experiences.

1 Like

which one do you use ?

1 Like

I log in to my email on my web browser.

2 Likes

@fsl4faisal, I'm using Evolution and seeing this behaviour too, and I think I have resolved the problem.

Go to Evolution Preferences > Mail Preferences and check Unset colors provided in HTML mails in message preview.

Thanks .. this solved the issue

1 Like