Executing grub-install/dev/nvme0n1 failed this is a fatal error

I am getting this error Every time I have tried installing zorin. It's a fresh install and just zorin not even dual boot. I would like to know the reason for this issue and how I can fix this.

Dell Laptop 3595
8Gb Ram
1 m.2 Nvme Ssd(256gb and 1 Hdd (1tb
Amd Stoney ridge gpu
Security boot - disabled
Sata mode - AHCI
TPM - disabled
(no legacy option available)

I would first verify the integrity of the ISO file that you downloaded to confirm it's not corrupted somehow. You may also want to double check that the USB or external hard drive you are using to install from is also working correctly, possibly even use another one for good measure.

Were there any error messages of any kind that you can show us? At what stage of the installation did it fail?

1 Like

Have you tried setting partitions manually?

Instead of letting the installer take over when asked about partitioning - choose Manual.

Now... Tons of debate on this one - and it's totally up to you, the newer installers don't use a separate home partition; you may if you wish to. I actually hated this, as I would always run out of space in my home partition, then completely screw everything up trying to free space or move / resize partitions for more junk lol...

So - decide on that..

Then - for your first partition: EFI, ~500MB - about as standard as standard could get (space wise). I think my installer chose 512MB, aaaand only using about 60MB on dual-boot.

After the EFI, create your home partition, if using, then all the rest ext4 - or whichever filesystem you choose. (swap is explained a little further)

Now - at the bottom of the installer, it has a drop-down menu on where to install the Grub. Choose the root of your drive, nothing else:

Screenshot from 2023-11-07 13-59-14

And of course, since you're using NVMe, you'll choose /dev/nvme0n1

Swap - I haven't left out swap, because this has changed over the years; some distro's still do use a separate partition for swapping, which would go after the EFI partition if you wish to have a set swap space. The way swap is handled now is through a 'swapfile', normally at the root of your drive - really easy to make / modify if you need more or less space. I believe the installer sets a swapfile of 2-4GB, I think mine was 2GB... but, I fly into the sun, live on the edge - all those phrases lol I run no swap.. but have RAM to compensate.

I've had to perform manual partitioning for this very reason, but for eMMC storage.

Other than that - have you tried booting the installer and ran the Boot Repair utility? Choose 'Recommended Repair' and let that run.. That usually repairs most issues / missing Grub / Grub entries. This is in the 'Try Zorin' live desktop environment.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.