External displays not found (Intel graphics)

Zorin doesn't find any of my external displays. I went to Settings -> Displays, but they aren't there. I then went to Software and Updates to check additional drivers, but nothing is there either. I tried to switch to Wayland, but the cogwheel to switch isn't there after I've logged out. Non of the tutorials I've found to try to install intel graphic drivers work, instead they are breaking my system more. Help!

I'm running a laptop with Integrated Intel graphics for Intel Core Ultra 5 135U vPro.

Intel has gone to use Open Source driver, so that's the reason trying to install old close source drivers would fail. I don't have intel, but if you try installing a newer kernel which contains the intel driver(s), it might find it.

YES!!!! Thank you for your answer! This fixed my issue!

For anyone else encountering this problem I followed Method 3 from this guide to update the kernel: https://phoenixnap.com/kb/how-to-update-kernel-ubuntu#ftoc-heading-8. I picked kernel version 6.8 since that's what the latest release of Ubuntu (24.04) is using. Not sure if that was the right choice but things work.

Issues I ran into

  • After reboot the system kept telling me this:


    The solution was to disable "secure boot" in the bios.

  • I got some warnings about packages having unmet dependencies after successful reboot. The solution was to use "Software updater" (Search for the app after pressing the super button). It asked me to do a partial upgrade, so I did, and the warning is no longer there.

1 Like