External displays not working on HP Omen laptop with Zorin OS 16.1. Works fine on Windows 10!

Hi all,

I have 2 laptops and 2 x 27" external Dell monitors. The laptops are a Lenovo T490 and and Omen HP 15-ax202na. I have a Targus dock which works perfectly on both laptops when running Windows 10.

The Lenovo is for work and the Omen is my own personal laptop. I have Zorin OS 16.1 installed on the Omen. This is where my problem lies.

It is dual boot with Windows 10. It does not have a USB-C port. Instead, my Targus dock comes with a handy cable so I can easily switch between my work laptop (USB-C) and my personal laptop (USB 3.1).

Basically when running Windows 10 via USB 3.1 connection to the dock, the displays and everything else work perfectly. When I boot to Zorin, it does not detect my external displays.

To work around this somewhat, I have an HDMI cable plugged directly into my Zorin laptop so it bypasses the dock and can use only use 1 external display. I would like to get both external displays working in Zorin but I can only do that using the dock since my laptop only has 1 HDMI port.

I did search the forum and 1 suggestion was to try using alternate Nvidia drivers in the Software Updater. The 1st one I tried was completely unsuccessful. After applying and rebooting, I had not 1 external screen but NONE. Also it couldn't detect my Wifi or ethernet so no internet access either. I had to restore a Timeshift snapshot to undo it.

I have these 2 big screens sitting in front of me that work fine when I reboot to Windows 10 on the same laptop with USB 3.1 connector to the dock but it just doesn't work at all on Zorin.

I also tried installing Nvidia drivers directly from their site but no joy.

Does anyone have any ideas how I can solve this?

Since Win10 is installed - do you have Secure Boot enabled in the BIOS / EFI settings?
Windows Secure Boot can interfere with Nvidia Drivers and installation on Linux.

By the way, I am currently (barely) dual booting Windows 11 with Zorin and I have Secure Boot disabled in BIOS.

1 Like

Thanks Aravisian. I checked the BIOS and secure boot is definitely disabled.
I wonder if many have had similar issues. I'm at a total loss here and would love to find a solution to this :slight_smile:

Can you please post the output of

sudo lshw -C video

Thank you. Output copied below :slight_smile:

       description: 3D controller
       product: GP107M [GeForce GTX 1050 Mobile]
       vendor: NVIDIA Corporation
       physical id: 0
       bus info: pci@0000:01:00.0
       version: a1
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list rom
       configuration: driver=nvidia latency=0
       resources: irq:135 memory:b3000000-b3ffffff memory:a0000000-afffffff memory:b0000000-b1ffffff ioport:4000(size=128) memory:b4080000-b40fffff
       description: VGA compatible controller
       product: HD Graphics 630
       vendor: Intel Corporation
       physical id: 2
       bus info: pci@0000:00:02.0
       version: 04
       width: 64 bits
       clock: 33MHz
       capabilities: pciexpress msi pm vga_controller bus_master cap_list rom
       configuration: driver=i915 latency=0
       resources: irq:131 memory:b2000000-b2ffffff memory:c0000000-cfffffff ioport:5000(size=64) memory:c0000-dffff

Can you try:

sudo nano /etc/default/grub

arrow key down to: GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

Add the parameter noapic to make it look like:
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash noapic"

Tap the ctrl+x keyboard shortcut to exit the editor. Then the y key to say yes to save. Tap the enter key to save the current configuration. The terminal will revert to normal.
Now you must run

sudo update-grub

for the changes to take effect.
Reboot and test...

Thank you Aravisian. I followed the steps and rebooted but I still have the same problem. No video detected through the Targus dock (but works on Windows 10).

Hoping there is a solution! Thank you :slight_smile:

I had a similar problem with two PC, one a Win 7 box and the other my Zorin Pro 16.1 hooked up to a KVM that enabled the use of one monitor.

According to the lads in the home office, it is possible Zorin has set the monitor to a "dummy" monitor, in other words, it does not see the monitor so the OS just presumes one is there. I suppose at that point the OS displays nothing.

If you go to the monitor that does not have the image and right click with the mouse, you may be able to see an option to select Display Options. From there select to make that monitor the Primary display.

1 Like

Thanks for the answers guys but I got it working!
It was a matter of finding the correct drivers for my Targus Displaylink DOCK180. The download link on the Targus site was broken and I had a really hard time trying to find it but eventually I found this github project for Targus docs:

If works on many distros including Zorin! It was very easy to install and worked a treat so I am now up and running with 2 monitors :slightly_smiling_face:

Thanks again!


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.