External monitor black screen

I've installed zorin pro but it detects my external monitor only if I select nvidia-450 or nvidia-470 and the monitor is always blank (black screen).
I've also installed latest drivers from nvidia website, same problem.
Please let me know, I love zorin

Hey there!

When you are trying to install Nvidea drivers, are you doing it through the "Software Updater" under "Settings" and select either the respective "Proprietary Driver" or you can use the "X.Org Server" choice.

Zorin OS supports most Graphic Cards by default allowing you to use Supported Drivers from Nvidea themselves as per above and/or Custom-coded drivers (please correct me if I am using the wrong terminology here) from X.Org / Developers of Zorin OS itself.

Or how else are you installing Nvidea drivers as it is supported by default in Zorin OS installation. (See below guide for reference)

Also, see this guide when installing Zorin OS: Activate NVIDIA Graphics Card - Zorin Help

If still suck, give us the peeps a shout here.

Cheers! :slight_smile:

Hi, I've tried all the nvidia drivers available into Software Updater, it detects my external monitor only using nvidia-450 and nvidia-470, but it has black screen. With latests drivers (525/515/etc.) on Settings>Display it doesn't detect my external monitor, same problem using the drivers from the nvidia website.

@damturbo , can you please post the terminal output of

sudo lshw -C video

I believe it's hardware related, correct me if you have conflicting evidence: aka it worked in windows or has previously. However I have suspicion that the hardware(if it's hdmi even) needs an active cable, the one you have may just be passive. I have encountered this often with HP, and most recently with my Lenovo. Getting an active dongle, or cable resolved this in both scenarios of mine.

1 Like
       description: VGA compatible controller
       product: NVIDIA Corporation
       vendor: NVIDIA Corporation
       physical id: 0
       bus info: pci@0000:01:00.0
       logical name: /dev/fb0
       version: a1
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress vga_controller bus_master cap_list rom fb
       configuration: depth=32 driver=nvidia latency=0 mode=1920x1080 visual=truecolor xres=1920 yres=1080
       resources: iomemory:fc0-fbf iomemory:fc0-fbf irq:79 memory:d0000000-d0ffffff memory:fcc0000000-fccfffffff memory:fcd0000000-fcd1ffffff ioport:4000(size=128) memory:d1080000-d10fffff
       description: VGA compatible controller
       product: Renoir
       vendor: Advanced Micro Devices, Inc. [AMD/ATI]
       physical id: 0
       bus info: pci@0000:05:00.0
       version: c7
       width: 64 bits
       clock: 33MHz
       capabilities: pm pciexpress msi msix vga_controller bus_master cap_list
       configuration: driver=amdgpu latency=0
       resources: iomemory:fc0-fbf iomemory:fc0-fbf irq:49 memory:fce0000000-fcefffffff memory:fcf0000000-fcf01fffff ioport:1000(size=256) memory:d1500000-d157ffff

it is a Lenovo but it was working with the same cable on windows

1 Like

I suspected, good luck then as I feel you're on the right path.

do you think I might buy an active hdmi cable even if on windows it was working with standard hdmi?

No, active vs passive cables are required based on hardware. If it worked with windows without it, then the hardware detection I suspect would be working; I cannot see how it would not from a different OS.

This may be a modesetting issue.
You might try:

sudo nano /lib/modprobe.d/nvidia-kms.conf

and commenting the following line options nvidia-drm modeset=0 so that it looks just like: #options nvidia-drm modeset=0
Tap ctrl+0 to save, then the enter key to save it under the current configuration, then ctrl+x to exit the editor.
Reboot and test...

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.