External monitor stop working after last update (AMDGPU)

Hello guys,
I am using your system (currently zorin 16 pro) for some time and like it a lot. But after last update (about a week ago), I can not longer switch between x server/wayland on login screen (missing cogwheel icon), in display settings I can not change resolution (default fullHD is set), and what is worst, my external monitor (old fullHD LG monitor) connected via hdmi stops working. I have MSI bravo 15 notebook with AMD Ryzen 7 5800h processor and Radeon RX 5500M graphic card. Thanks to timeshift I was able to undo last update, but I can not update my computer anymore until I find solution. Also, changing kernel to different version changes nothing (I even tried to install latest kernel from kernel.org). I tried some advices from little bit similar topic (https://forum.zorin.com/t/monitor-refreshes-when-playing-video-skipping-etc/14627).

Update of "graphics-drivers" installed something, but did not resolve my issues.



"quiet splash amd_iommu=on iommu=pt"
"quiet splash amd_iommu=off iommu=pt"

also does not help.

inxi -Faz

showed my following:

Device-1: AMD Navi 14 [Radeon RX 5500/5500M / Pro 5500M]
vendor: Micro-Star MSI driver: N/A bus ID: 03:00.0 chip ID: 1002:7340
Device-2: AMD vendor: Micro-Star MSI driver: N/A bus ID: 07:00.0
chip ID: 1002:1638
Display: x11 server: X.Org 1.20.13 driver: ati,fbdev
unloaded: amdgpu,modesetting,radeon,vesa compositor: gnome-shell
resolution: 1920x1080~77Hz
OpenGL: renderer: llvmpipe (LLVM 13.0.0 256 bits)
v: 4.5 Mesa 22.0.0-devel (git-8599ded 2022-01-29 focal-oibaf-ppa)
direct render: Yes

In setting -> about is graphic as

llvmpipe (LLVM 13.0.0, 256 bits)

So for some reason, amdgpu driver is not loading.
Unfortunately, I have little to none knowledge on this subject. Any suggestions?

Can you look at:

  1. External Monitor not Detected
  2. Updated Zorin 16 Base, External Monitor No Longer Detected

Also, what’s the output of sudo lshw -c video?

Hi, thanks for answer. Meanwhile, I backed up my whole hard drive, downloaded zorin 16 pro iso again (found out, that it was the same as the old one on my drive) and did fresh install. Then I did update & upgrade and... everything is working as expected. It is kind of weird, because I did not do any experiments with graphic driver or something like that. Anyway, problem is gone and I am going to spend lovely evening installing apps :smile: Thanks for help.

Glad it worked. Please mark your response as the solution.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.