External Monitor not Detected

Hi;
Im a dutch zorin/linux beginner and i switched from win 10 to ZorinOS 3 weeks ago.
using it for 1 laptop and 2 desktops (HP DC7900 and DC6005pro.)
and my oldies working great again.I really like this OS, (zorin os 16 pro)
I understand linux notyet, but soon i will see the linux light :-), in stead of windows :expressionless:

But unfortunaly my laptop does not detect the external monitor (Samsung LE26S81B)
In the Display setting: "Unknown Display" /landscape,
the screenresolution 1920x1080 is and unfortunaly not adjustable
The 2 Desktop are working very well,with the same secundary monitor/tv.

i think that the problem is a display driver,
the bios: Nvidia n13m-ns1, 1024mb display 15,6 FHP.

Can anybody help me with my problem ?

Thank you

Device name: Dell Latitude E6530,Memory 7,7GiB : 1Processor:Intel® Core™ i7-3540M CPU @ 3.00GHz : Graphics :llvmpipe (LLVM 12.0.0, 256 bits) : Disk capacity:128,0 GB

Check Software Updater -> Settings -> Additional Drivers. If you have multiple options in them, try them. Make sure you click the Apply button when installing each of them.

Is there another output you can use? For example dvi vs vga vs hdmi?

Also, can you provide the output of sudo lshw -c video ?

1 Like

Thanks for your reaction carmar, ill appreciate you.

But there'ś no driver to choose from, i can't change the settings,
i have tried all 3 of the outputs off the laptop(hdmi, vga ,en DVI too (i have those cables) Visually i see that that there is a short connection to the external monitor, (and the message on screen : no signal)

*-display
description: VGA compatible controller
product: GF108GLM [NVS 5200M]
vendor: NVIDIA Corporation
physical id: 0
bus info: pci@0000:01:00.0
version: a1
width: 64 bits
clock: 33MHz
capabilities: pm msi pciexpress vga_controller bus_master cap_list rom
configuration: driver=nvidia latency=0
resources: irq:16 memory:f5000000-f5ffffff memory:e0000000-efffffff memory:f0000000-f1ffffff ioport:e000(size=128) memory:c0000-dffff

i see a lot with the command:" sudo lshw -c video " thanks :slight_smile:

If you can’t select the 390 driver, try: sudo ubuntu-drivers autoinstall

2 Likes

@thenor Also this:

...is pointing to "Main Server" as source, rather than any local server.

1 Like

Hi camar. im sorry that i react late, but there is personal matter for it.
ive succeeded with the sudo lshw -c video and i saw 3 choices and i (stupid as i am ) picked the middleone, bad choice of me, ((it should be the third choice))
so the current message is now: there is a message: Oh no! something
has gone wrong. A problem has occured and the system canẗ recover. Please log ou and try again"

So i have installed a new zorin os 16 (light version) and with the new installed version my external monitor works perfect.
And now i also know what i have done wrong, {stupid as i am)
i have changed someting in the bios graphic section. (something like Nvidia prominus) so i was thinking " if i enable this switch then maby the OS will see the Nvidia hardware and will install the best availlable driver" but that Nvidia button in the bios will destroy the display driver"
And now i have a problem because i have enabled this nvidia diver and there is no way back.
disable the graphic swicth to disable does not solve the problem.

So my question is now , can i restore the previous zorin, or is it possible to get my documents and downloads out of this broken zorin.
and then i want to reinstall zorin os 16 , but then the lite version.

I hope u are understanding the above, because my english is not that good, but i try not to use google translate.

thank you

thenor

today i have tried it myself and learned a bit.

i have ```
dpkg -l | grep -i nvidia
and
sudo apt-get remove --purge '^nvidia-.*'

then : ```
udo apt-get install ubuntu-desktop

and: ```
echo 'nouveau' | sudo tee -a /etc/modules

and then some cleaning with : ```
sudo apt autoremove

and

thanx for all the advices and help.

thenor

Sorry, that’s a lot of detail and I may be missing some of it.
As I understand, you have the monitor working but something else is wrong with the system, correct? Could you explain why you’re unable to access your documents for backup?

hi carmar , i was aiming on my documents, that i had stored on the first zorin os, but i have fixed it.(with the above commands) and i have my documents copied.

Now i have installed zorin 16 os pro lite on my laptop and every thing is working great again.

thenor

1 Like