External monitor stuck in glitch display mode

Hi all, thanks in advance for your time.

My setup is a laptop and and a monitor. I don't know what happened / changed, but now my display is glitchy. It's like the two screens are locked in a mirror mode, but they each have a display partially stacked ontop of eachother. Check out the embedded pictures below.

I've tried:
Playing with the gui display settings.
Xrandr -o normal.
Xrandr -s 0.
Plugging in a different brand monitor (same problem with second monitor)

CPU~Quad core Intel Core i7-2670QM (-MT-MCP-) speed/max~798/3100 MHz Kernel~5.4.0-122-generic x86_64 Up~3:05 Mem~1691.3/5848.1MB HDD~750.2GB(5.8% used) Procs~311 Client~Shell inxi~2.3.56
Zorin OS VERSION="15.3"
2011 Toshiba satellite


If this is a recent development, it may be an updated release of the kernel that is not playing nicely with your hardware.
Can you please reboot and select Advanced Options for Zorin from the grub menu (Tap the esc or the tab key at M.B. Splash screen if you need to in order to see the grub menu) and boot from the Earlier Kernel and test.

Nice thought. I just tried booting from an older build. I'm still getting the monitor issue though

The only thing you don't have listed in your specs is the gpu... which could make a big difference. Also, have you had any problems in games/videos on single or dual monitors?

I'm trying to figure out if it's a hardware issue or not. Did the graphics driver get updated in the last kernel update? It may have switched drivers, to a newer release or version. Rolling the driver back may get different results (if it's not the hardware).

It's lumped into the cpu via an old intel integrated graphics they called "HD graphics 3000". I think the cpu doesn't get drivers.

I haven't gamed on this comp in a long time, but videos have never given it issues before.

Sounds like a radeon card, which shouldn't need drivers as they are already in the firmware.

Have you tried upgrading the firmware alone? It is a new enough machine that the 15.3 firmware may not have the correct driver (and it will not be listed under other since AMD went open source).