Extra RAM not seen

Yes, the bios will see the module, I've seen this happen before, could be defective ram, or dust in the slot, or improper seating, in windows this will show as Unusable ram. The BIOS grabs the memory information from the micro-controller off the dram module, which announces what it is and how much memory is available - Modern PCs no longer memtest on boot like the pc of my youth lol this is to save on boot time (used to take 30 seconds to do a few hundred kb)

I think before doing anything else download and run memtest86 and verify the ram is actually good. Could be a defective stick,

Seeing as the Laptop came from the manufacturer with the added Samsung stick do you really think it could be incompatible as that would be a bad decision by Lenovo as this is also the RAM they suggest to use from their website with this model ?

As an experiment, have you tried swapping over the new RAM and old RAM in their slots to see if anything changes. i.e. the fault moves. It may determine if it is the RAM or the slots at fault.
Maybe worth carefully cleaning the slots and the RAM module edge connectors with some switch cleaner (isopropyl alcohol).

After running MemTest86 I have found some interesting results. In the picture below it shows that only the extra RAM is being used and that the RAM soldered to the motherboard is not seen.

Upon further inspection of the extra RAM it initially shows it is the correct speed of 2400MHz which is what both types of RAM should befor this laptop.

But on later pages of the description it Shows it as being 3200MHz RAM as shown below.

Could this be why it is only seeing the secondary set of RAM and if I were to replace it with one at 2400Hz would it then see both ?

Soldered in RAM may not report SPD info. See this: MemTest86 - RAM SPD Issues

1 ram module is soldered and the other one is not.

The difference between the speeds is actual and max values. It can run at 3200, but on average runs at 2400 (sort of like cpu speeds)

So now that I know the RAM isn't faulty where do I find if there is a BIOS update available for my laptop as the one in the suggestion is for a different model processor ?

You can use Lenovo vantage to update bios or do it manually if there is a update.

1 Like

Ah yes I had already found the manual file on the Lenovo website but it is just a .exe file and I am running a Zorin only machine will it still be possible to execute this file in Zorin through wine maybe as they do not have a .iso file available for me to add to a bootable USB or is there a way to get Lenovo Vantage running to do it for me ?

Use windows for that, dont try to use wine for it.

Oh I see so it can be of a higher speed but it will only run to the systems abilities.

And I suppose that if it were slower than it would just cause a bottle neck in the system but still work at a slower speed?

As I said I have no windows setup on this machine so that is not possible is there a way to create a .iso or .img file with this driver on it ?

It refers to the possibility, if necessary, for the speed to be increased to 3200 by the system. That would occur if a bottleneck occurs (meaning it isn't processing [storing, releasing memory] fast enough to handle what is being passed to it). Most RAM today is variable speed, determined by the CPU as it handles requests (this is usually determined by the MB manufacturer by supporting certain CPU die sizes. While the CPU may modify what speed it accesses RAM, it isn't changed often. This provides the MB manufacturers the ability to support more CPU and RAM combinations).

Nice to know thank you.

Download the Windows 10 PE, write the .ISO file to a USB stick, then boot it. Then run the .EXE file for your BIOS update.

I did the same in attempting to update my BIOS, and the .EXE file that creates the UEFI / BIOS update ran alright... the problem for me was that the key InsydeByte (the BIOS manufacturer) used isn't compatible with my UEFI / BIOS, so the update failed. I'm still looking for a resolution to that. HP... they make great hardware, very iffy software.

If it is of any help .....

I have a Dell Latitude E6510 what is an older, but great machine with an i7-840QM and can handle a load of DDR3 -- 16Gb (!!) 8Gb / RAM-bank is now the maximum you can buy in a normal situation. Should DDR3 - 16Gb exist it would work as well for 2 x 16Gb .

I had the issue that RAM was not recognized in my expansion slot. The main slot was perfect. I swapped the banks and both worked fine in the main slot. The expansion not however.
I did a close examination of the slot and all that is related to it. To make the story short : I noticed on the RAM-clamps left and right of the expansion slot 2 small metal lips pointing inwards of the clamps or springs of the Ram expansion bank.
I took pliers and bended those small 'lips' downwards. Inserted the RAM and that solved my problem in total !! RAM expansion was recognized, BIOS saw the extra 4gb and Zorin showed in the info of the settings -- 8 Gb RAM (2 x 4gb DDR3 ) . So a long search in the software and Bios came to an end. It was hardware related --- the RAM - clamps / 2 fragile small lips at the bottom of those clamps (or springs) / bended them away and inserted the RAM = OK 100% working.

Maybe this experience counts for you as well. This you have to try.

1 tip extra I learned from a HP Elitebook: when you insert the RAM, push it firmly into the slot, it may lower 0,5 - 1 mm extra and that makes as well the part of recognizing the RAM or not. Set your both thumbs to the slot and take your fingers to squeeze firmly onto the RAM-bank so it is maximum inserted in the slot. Then click it into the clamps. Boot and verify in the BIOS if it is accepted.

Thank you for the information on updating my BIOS but even though it is now on the newer revision my RAM problem is still seems the same but I have noticed the RAM test in terminal now shows the Phrase Row of chips in the From Factor status where it previously said SODIMM as seen in the picture below

I have also noticed a change in the terminal with the Free command now showing different values in the Used,Free,Shared,Buff/Cache and available sections to how they used to be.

New Memory Status 2

I'd be more concerned with your second RAM stick showing all zeros for the serial number.

The serial number is in the SPD (Serial Presence Detect) data, which is in a small chip on the RAM stick. The SPD data is read via the SMBus. It might be that the chip that holds the SPD data is bad on that stick.

"row of chips" just means it's soldered to the motherboard.

In regards to the "row of chips" status is there any reason why it originally said "SODIMM" before but now it's different ?

not only that but the mentioned RAM is the removable one the second one listed is the Soldered RAM or am I seeing this wrong ?