"Failed to create a file system" on Acer Aspire One Cloudbook 14 (AO1-431-C8KZ)

Hello everyone.
I got this Cloudbook from a friend and it's been impossible to install Windows 10/Zorin on its 32 GB eMMC drive. It's not detected by the Windows installer on UEFI boot mode, and on Legacy boot it doesn't let me install Windows on the drive.

After asking for help on other forums, I was told to try Linux.
I got some errors during the installation process (which failed).

  • Input/output error during read on /dev[something]
  • Input/output error during write on /dev[something]
  • Error fsyncing/closing /dev[something]: Input/output error

Could my eMMC drive be dead? The one thing I noticed was that browsing through the files using the Windows installer, there was a "Boot" partition (which I originally assumed to be part of my USB drive) with some files on it. Turns out they belong to a Windows 10 installation, so at least it is possible to access the drive.
Also, I used Windows-To-Go to update my BIOS to the latest version. No luck.

Here's some pictures of the errors I got installing Windows 10.

This showed up after exiting the installation, IIRC.

I hate to say it but I think you are on "a hiding to nothing". eMMC notebooks IMHO should have been scrapped at the concept stage. They aren't really meant for serious computing, just browsing and emails. There is not a lot you can do with eMMC notebooks and if any component fails it becomes instant e-waste, another waste of the planets resources. I'd suggest you buy yourself a humungous USB stick and make it persistent to boot off that. Better still, if you can save enough spondoolies, to buy a decent notebook with a bare minimum of an i5 Processor and 8 Gb RAM. There are tutorials on how to install GNU/Linux elsewhere on eMMC notebooks but may not always work.

Are you set to AHCI or to RAID?

I've looked for that in the BIOS extensively, and there's no option remotely similar.

It's just secure boot/UEFI&Legacy/BIOS passwords/boot priority/and some TPM thingy.

I disabled secure boot and the TPM module.

I just want to use Google and maybe Office. I also can't afford buying another laptop. Booting from a USB stick forever is an option, but I want to use the eMMC storage. What tutorials do you know to install Linux on eMMC drives? It seems to me that there's a problem with the computer itself, not Linux, as Windows failed to install too.

I can't set the UEFI trusted file.
Going into "Select an UEFI file as trusted for executing" doesn't show an "EMMC" option, like it does in the video. It shows nothing.

See if this thread helps:

I tried following the instructions using Zorin on a USB, but the eMMC drive is listed as "read-only" and it won't let me format it, create new partitions, or write a disk image to it | Screenshots of the errors

Attempting to format the disk returned this error:

Error formatting disk
Error wiping device. Failed to probe the device '/dev/mmcblk0' (udisks-error-quark, 0)

Creating a new partition.

Error creating partition
Don't know how to create partitions this partition table of type '(null)' (udisks-error-quark, 0)

I did see some comment that that partition (first one you quoted) holds the Certification of the version of Windows installed and it cannot be deleted. Saw it on a different forum pertaining to Windows 8.1.

You got a link to that post? Would any SSD tools reveal if the chip has completed its write cycles?

I found a couple of people on Reddit with the exact same problem as me, and the same laptop too. They said their laptop stopped booting one day, for no apparent reason, and none of them had a solution.

I'm afraid this sounds like a dead drive.
Thoughts?

Basically, that sector is unwriteable - it is hard-coded - yet another reason not to buy eMMC machines built for Windows or Chrome. Sorry to be the bearer of bad news. The drive isn't dead for the original OS that was meant to be on it. Your only other option is to have a large SD card or USB drive, even a portable one that can be booted off that first - don't know what the BIOS in your cloudbook allows in respect of alternative boot media.

Don't know if this is of use:

or this:

The entire 32 GB eMMC drive is unwriteable? That makes no sense. How do people install Linux then? I tried using GParted as the superuser post mentioned, but it doesn't even detect the eMMC drive. Booting Windows off of an external hard drive and opening disk management doesn't show it either.