Failed to open, error when getting information for file

I added some folders from local disk and another partition to the Places ( quick access) on the left side menu but every time I start up my system it's giving this error

Is the drive that links to that Media directory mounted?

it's folder in my local disk and another folder from another partition, 1st it's giving this error once I'm opening the folders 1 time my self then the shortcut in the places start working
image
1st folder Mylecs located in the local disk
2nd Folder Trash located in 500 GB Volume

What file system is that 500gig partition formatted in?

if you mean about NTFS so it's NTFS

1 Like

Both partitions local disk and 5oo GB NTFS

@Aravisian Any Ideas ?

It's not mounted at boot, so the quick access bookmark doesn't know where to find it.

You will have to add an entry to the /etc/fstab for it to be mounted at boot, eliminating the need to open file explorer (nautilus) and accessing the location (mounting it) prior to the bookmark working.

The FSTAB entry will look like this:

UUID=01D6A3FED72BF050 /mnt/vault ntfs-3g defaults,umask=022,uid=1000,gid=1000 0 0

You can get the UUID from your disks, which is EECA2487CA244DE1.

The mount point will be the location you have configured for the bookmark: /media/blackjoker/EECA2487C244DE1

everything else gives you the driver, permissions and ownership to access the drive as you want to.

So everything together would be:

UUID=EECA2487C244DE1 /media/blackjoker/EECA2487C244DE1 ntfs-3g defaults,umask=022,uid=1000,gid=1000 0 0

Copy that to the end of the /etc/fstab and it will mount on boot.

2 Likes

Sorry for the delay. I hope @337harvey's answer helps.

1 Like

@337harvey can you please provide me more info about how to do that

Open terminal and type sudo nautilus. Then navigate to /etc/ and double click fstab, it should open in gedit (gnome text editor). Copy the line i have assembled for you.
Create space in the file by hitting return a few times.
Paste the entry.
Save and close everything.
Reboot.

It's just editing a text file.

as you can see I got problem with that

** (org.gnome.Nautilus:27159): WARNING **: 19:24:35.209: Unable to get contents of the bookmarks file: Error opening file /root/.gtk-bookmarks: No such file or directory

** (org.gnome.Nautilus:27159): WARNING **: 19:24:35.210: Unable to get contents of the bookmarks file: Error opening file /root/.gtk-bookmarks: No such file or directory
Nautilus-Share-Message: 19:24:52.250: Called "net usershare info" but it failed: Failed to execute child process “net” (No such file or directory)

These can be ignored. When you open Nautilus in Root, it cannot access the Bookmarks file which is stored in Home.

@337harvey


Here it is fstab file which in etc
I added the last 2 lines as you show me but after reboot still same error

Try changing the mount point to something other than the uuid, a name for each. Then delete the bookmarks and re-add them to reflect the new mount name.

1 Like

@337harvey after I did that it worked only 1 time after restart the system but after start up same problem happened the partitions not mounted


here is my fstab file in etc

@337harvey actually I noticed that nothing mounted in the system always only the File system partition and all other partitions not mounted always and I need to open it then it's mounted each time I start up the system

It is because the renamed UUID variable in the two lines. You can add a comment before or after the entries with a # symbol at the beginning of a line. Use this method to define E drive and the other. The first variable must be UUID or it won't work.

This is why they aren't mounted. Make this change and you will notice both are mounted at boot.

Once that is done x you may have to remake your bookmarks. Before you do, verify that they are mounted.

@337harvey Now I can't edit and save the fstab file

You have to edit as super user (root) because it is a system file. Just as when you first added the entries.

You can do this easily with the terminal command: sudo gedit /etc/fstab.

Don't close the terminal until you are finished as this will close the gedit window as well.

I hope you realize you commented out the Edrive line. Before the = sign, hit enter, then on the new line add the UUID. This will ensure you are labeling what follows and create the entry that the system needs to perform the mount. Ex.:

# EDRIVE

UUID=EECA2487C244DE1 /media/blackjoker/edrive ntfs-3g defaults,umask=022,uid=1000,gid=1000 0 0

As you can see, I labeled the entry, and also changed the name of the mount...this of course is whatever you want it to be. You may want to use names that define what it is, so as not to confuse yourself. LocalDisk, while appropriate for what it is, may be better as windisk, or some other descriptive name. My drives are named for what they are, Win, Vault (data storage), Backups...you understand what I mean? This will help avoid confusion for you in the future.

You must reboot for changes to the fstab to take effect.

1 Like