Failed to update message (Zorin 16pro to Zorin 17pro)

The message I get is:
Detailed errors from the package manager follow:

failed to build result for 362301da643102b9f38477387e2193e57abaa590

Is there anything I can do to fix this? Thanks

1 Like

If there was nothing specific details about what went wrong, it's hard to say. You can explore the forum for similar threads and hopefully find something that helps with it.

However, for a Pro user you can reach out to the developers for help on this matter. In the confirmation email of your purchase of ZorinOS Pro you will find an contact address for support with installation.

1 Like

Did you folkow the official guide on upgrading?

I have exactly the same error message "failed to build ..." since I upgraded from Zorin 16 Core to Zorin 17 Core. And I followed the official guide on upgrading (which is pretty straightforward, btw).
I'd be glad if anybody had an idea on how to solve this.

@mycoma and @Jerome, if you both can please chack your sources:

Be sure to look in /etc/apt.sources.list.d and ensure that the Zorin OS repository files are assigned correctly to your build, as well.

I had the same issue and contacted support. They recommended I run sudo rm /var/lib/fwupd/pending.db and it worked for me.