Fancontrol-GUI vs Coolero?

In an effort to fix my ongoing fans-running-full-speed-all-the-time (one of the reasons I dumped Windows altogether, but still manifesting the same issue in Zorin), I took the plunge and repasted my CPU/GPU. This had such a noticeable effect that I wondered if I'd forgotten to plug the fan back in when I reassebled things (yes, it was that quiet!).. so I followed a guide to build and install fancontrol-GUI. This installation didn't seem to work, or at least worked in some fashion, but with lots of errors in the process (I also followed an Ubuntu 18.04 guide so maybe that didn't help things) .. when I was unable to launch the tool, some more research unearthed Coolero, which I was happy to see available from the Software center. This installs and launches fine, but seems to show that my fan is running at 100% non-stop (even though it's close to silent, at least compared to how it was pre-paste!)

So my question is.. How would I remove the previous fancontrol-gui? Is there a guide I can use to sort of replicate in the future that I cam apply to any similar situations?
I'd love to learn how I can sort of check to see what I've done previously so I can reverse it -- kind of like in Windows where I can sort apps by installation date (I fully get that it won't be "that easy", I'm just using it to flesh out my request)

Have you checked this thread?

Thanks for this - I tried a couple times until I remembered that I hadn't downloaded any package to work from, so visited the original link to get more information.. this showed me the directory I'd installed it in, and even provided the same sudo make uninstall command you linked to.. however this now returns this error:

Cannot find install manifest: /home/username/fancontrol-gui/build/install_manifest.txt

I tried the sudo checkinstall command but it just kicks back "command not found".

I actually realized from some purple links in my browser that this was the install process I followed vs the one on the actual site, is this what was my undoing?

The checkinstall package is software that needs to be installed in order to work.
When I made that post- the package was still valid. I believe that in the time since, checkinstall has dropped out of maintenance and is essentially depricated and no longer valid.

Your link leads to "Page not found"

This almost always means that the command was run from the wrong directory.
You can see in the path it posted:
~/fancontrol-gui/build/install_manifest.txt
Is there a file named install_manifest in that directory? If not, is it elsewhere in that tree?
If it is not present anywhere... It may be generated from the Make Install commands.
In which case, just repeating the installation procedure; then running the uninstall procedure should resolve that issue.

1 Like