File selector response very slowly after upgrade to Zorin 17

A few months ago, I upgraded from Zorin 16.3 Core to Zorin 17.1 Core. I am very happy with the update, but the file selector has been extremely slow since then.
When I select a file in any program, the Zorin file selector opens by default. In my case, when I click on the corresponding button, my entire Zorin becomes very slow and jerks, as do all other applications. Then the file selector opens in slow motion (usually within 2 to 10 seconds).
If I then select a file directly without clicking on another location, it usually still works, even if each individual click takes seconds to trigger a reaction.
However, if my target file is in a different path than the one selected by default, I have to open another path (e.g. the Downloads folder). If I click on this path in the left-hand column, the selector sometimes takes up to a minute to load - in some cases it even displays a message that it is no longer responding and that I should kill it.
All in all, it often takes me several minutes to select a single file.

I should also mention that it can't be my PC - I have M2 SSDs, 32GB RAM and a Ryzen 9 installed and apart from this one bug, Zorin is really very fast.

Many thanks in advance!

Hi, are you using Snap or Flatpak Apps? Also are you always using Zorin on Wayland or Zorin Desktop on xorg?

The problem occurs on both, flatpak and snap apps. And I think I'm using xorg (thats the nvidia-solution, right?)

Well first, if possible, use APT packages if available in Software. You need to use the drophdown arrow, Zorin APT is usually the last option due to Alphabetical Listing of versions, F, S, Z. No, xorg is not the nvidia solution. GNU/Linux has proprietary free drivers for nvidia cards called 'nouveau'. Xorg has always been the default Compositor (this is what draws the desktop and windows). Zorin 17 now uses Wayland by default (a bad move). When you select your username at login you should see a cog, click on this and change it from Zorin on Wayland to Zorin Desktop on xorg. I would check to see in Software if you have apps available as APT before removing your Snap, Flatpak packages. If I was still using Zorin, post install would involve:

  1. Disable Wayland;
  2. Removal of Snap and Flatpak.

Unfortunately, I can't find the gear you mention. But I ran echo $XDG_SESSION_TYPE in the terminal and it returned x11 - so it seems I'm still using xorg.
And I'm not planning to move away from Snap or especially flatpak. On the one hand Zorin is based on Flatpak, on the other hand I have had very good experiences with Flatpak. Apart from that, my problems with APT packages are the same.

Did you clicked on Your Profile so that the Password Field appeared? Because only then is the Gear Icon in the botton right Corner visible.

Yes, I did.

Did You tried a sudo apt reinstall nautilus to reinstall Nautilus?

No, not yet - but now I've given it a try. When I uninstall Nautilus, the file explorer is gone, but the file selector still works. Accordingly, these packages seem to be independent of each other.

Can you better explain (e.g. illustrate with screenshots) what you mean by "file selector" and "file explorer". I think we need to be be clear what the problem is.

Nautilus (aka "Files") is equivalent to File Explorer. So not sure what you mean by File Selector.

This is what I mean with file explorer (and yes, this is nautilus):

And this is the file selector:

When it runs so slowly, died You take a Look in the System Monitor to look if Your Hardware works hard in this Moment of Usage? I know, You have written Your Specs in the first Comment and they are way more than enough.

I have looked at the complete CPU load using the Sysmtem Monitoring Center program: At idle (with background programs) the CPU was at about 1% to 2%, when I open the File Selector the usage goes to 3% to 6% for a short time. So everything is actually within limits.

Hmm ... when it not depends on Wayland/Xorg ... Maybe it is a Driver Problem? You use Nividia?

Re-reading the title of this thread says "...after upgrade to Zorin 17". So this was result of using the ZorinOS Upgrader tool to get to Z17. Maybe that is significant.

I wonder if Upgrader has left old repositories or something similar behind that would not be seen from a fresh install. Maybe worth investigating.

By chance, I have now found a solution to the problem: I wanted to start my PC today, but then realized that the GUI did not start. After a little research, I found the following solution:

  • Open terminal via Alt+F3
  • Enter sudo apt purge gdm gdm3
  • Reinstall with sudo apt install gdm3 ubuntu-desktop.

This also seems to have solved my problem with the slow file selector.

However, the Zorin desktop is now gone (I still have the background image, but all files on the desktop are no longer displayed and I can't add any new ones) and the tabs layout and Work interface in Zorin Appeareance are completely empty. Does anyone know how I can fix this problem?

Nvmd, the problem is back. Too bad, would have been too nice if it had been solved ._.

That is because You installed ubuntu-desktop. That is the Desktop that comes from Ubuntu (Zorin is based on Ubuntu). For Zorin it is called zorin-os-desktop but theoretically You should be possible to choose it on the Login Screen when You click on the Gear Icon like describted above. There you can choose between the Desktops. and because You didn't uninstalled the Zorin Desktop it should be still there. But when You don't have the Gear Icon, I don't know how You can choose the Desktop.

But You could try to install/reinstall the Zorin Desktop and look if it works. To do that open the Terminal and type sudo apt install zorin-os-desktop and when this don't do anything because it is installed, try sudo apt reinstall zorin-os-desktop and for Zorin Appearance You could try the same but instead of zorin-os-desktop You write zorin-appearance in the Command.

Thank you, that worked. Unfortunately, I'm back at the beginning now... xD

I don't like to ask, but ... Would You try a fresh Install of Zorin 17?