FILE's "Windows Network" finds no Windows network shares

FILE's "Windows Network" finds no Windows network shares.
They exist, other networked (Windows) PCs find them, but not Zorin.
(Under a different post I am pursuing why my SMB connection has suddenly stopped working.)

Thanks all

Zorin OS 16.3

Are you running a firewall? Did you allow network discovery when you first connected the computer to the network? Were the shares ever accessible from zorin? Is your computer configured correctly to see the shares? Is the router? Do you have a firewall on your router, or limit share access by Mac address on the router?

Sorry for the unhelpful request for help. I was attacking this issue in a whole other way (in an unrelated post) and forgot to include that info here. Mea culpa.

A long-good SMB connection is now failing and I thought since I cannot get that path to the windows share working I thought I'd ask about FILE's built-in Windows network browser, ergo this post.

The link smb://pcname.local/sharename was working for the longest time to connect me to a drive on a Windows machine and suddenly it does not.
Fine. I removed and re-added the SMB connection in Zorin's "Files" making sure to use the correct user ID, workgroup, and password.
I know they are correct since after re-adding the connection and still seeing a failure I even reset that info on the host PC!

I am getting the error:
Failed to mount Windows share: INVALID ARGUMENT

If I use the format smb://pcname.local/sharename I do not get asked to log in, there are just a few moments before it fails to that error.

If I use the format smb://pcname/sharename I DO get asked to log in, then it fails, same error.

Connections to the same host/share are working for the Windows PCs on the network.

My Zorin install has smbclient "Version 4.15.13-Ubuntu" installed.

Zorin's built-in firewall

On the host PC, yes. I don't remember having to do anything like that on the Zorin PC and it was working.

Yes, yes.

Only outward facing, not for the internal LAN. And, no.

If for whatever reason the SMB method doesn't work I was hoping I can get the "Windows Network" browser working but it doesn't see any shares at all.

Error: Failed to retrieve share list from server: No such file or directory.

I wonder if FILE's "Windows Network" browser won't find anything on a peer-to-peer setup.

Thanks all.

Zorin OS 16.3


Have you tried including the username in the smb url? smb://user@pcname/sharename
Many how to's and stack overflow answeres provide this method as windows ties the share to an user account. It will have to be the user of the computer offering the fileshare.

1 Like

Sorry, yes that also fails with same error. So odd that it was fine for so long...

Have you tried using the ip address instead, in place of the computer name?

Maybe a router restart? How often do you restart the router?

Was the name service on the host machine shut off by an update (windows does this occasionally). Maybe turning the service off and back on, or restarting the host machine?

1 Like


In Terminal entered this command to install additional software to allow connecting over SMB:
sudo apt install cifs-utils

I don't know why I had to reinstall the cifs utils, but there you go!

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.