Find out what's going on/where to begin

I'd like to know the easiest place/way to find out what is happening when I'm online and things start going funny. I open the system monitor but I don't know what to look for to find nefarious entities playing havoc on my web activity. I've asked previously about getting my router settings right to avoid unwanted behavior but I think I should first find what's doing it by some means if someone can tell me. Then I can take the appropriate action towards whatever it is.
Just now I'm on my Firefox browser (I don't have windows on my computer) in an article I'm reading and my mouse stops being able to scroll, instead I have to access the bar to the right of the page to get the page to move down. When I try backing out of the article by xing out of it there's a very slow response. I click on the video I have paused on another tab and that response is really slow, so slow I think it's not responsive but it finally catches up to what I'm asking.
In this troublesome setting where do I begin to see what's happening? Is there a tool I can install that will lay it out simply enough for a new Linux user? And I emphasize SIMPLY please!

1 Like

You could take a look on your router at the 'active DHCP leases', if available, to see if anything is connected that shouldn't be..

Firefox - do you have 'Hardware Acceleration' enabled? Get a lot of weird things going on with just browsing non-video hosted pages and most other non-intensive web browsing. I would see if that's enabled - even with an 11th gen i7 octa-core and 16GB RAM, I still have issues. The same machine that can run most all new-ish games without an issue :person_shrugging:

I don't know of anything other than the Sys Monitor and looking at the RAM use and CPU utilization; will show any apps taking a lot of resources. I'll take a look around if someone doesn't beat me to a suggestion lol I've not had to use anything other than the Sys Monitor - but I get what you're saying for sure. It sounds more like it's just running out of RAM or CPU.. How much RAM do you have and what CPU are you using?

1 Like

On Firefox you can click Open application menu > More tools > Task Manager and see if there's an abnormal usage. It's also worth trying to restart it in Troubleshoot Mode, that's on Open application menu > Help. I suggest this because I noticed a slight speed improvement on Firefox responses once restarting it with all extensions temporarily disabled. This mode is safe, temporary and lasts only for the next session that you start from the Troubleshoot Mode prompt.

1 Like

I went to Firefox setting and you have to uncheck "Recommended Performance" in order to get to the place where you check whether you want "Use hardware acceleration when available." I took off "recommended performance" and then unmarked "use hardware acceleration when available."
And, I went into the router settings and there is a Guest DHCP there. I have the printer which is setup for both wifi and hardwired router connection. I have my phone which is wifi. Those two devices are all that go through the router. Are these other devices what the Guest DHCP is about or is that something else altogether that should be looked into?
I will check the taskmanager in firefox when trouble happens so I've written that info down. I'll try the troubleshoot mode also.
Jarvis can be installed from where?


Guest WiFi output can be disabled, people look for that and try to jump in without the knowledge of the owner..

How much RAM and which CPU series do you have in your machine?

I have 7.5 GB with 11th Generation Intel Core i5-1135G7. Under system monitor is says 7813592KiB with 1010000 KiB available.
I tried to disable the Guest profile in my router. Under LAN IP address allocation I could disable that but it's still listed under DHCP.

Might still show in the list after disabling, my old firmware did that before I switched to OpenWRT. As long as you aren't transmitting a 'Guest' network, that should be it.

That's plenty of RAM though; maybe not for a lot of things open / running, but enough for a good bit .. What graphics card do you have? Other than maybe something with drivers / hardware - is the machine getting pretty hot? Could be time for a good air-dusting. When fans start collecting dust / debris, it decreases the effectiveness of the air flow; sometimes almost all of it.

And one other thing I could think of - what does sysctl vm.swappiness show? Anything above 60 and that's abnormal; was thinking possibly could be swap related. I can always tell when my other machine with only 4GB RAM starts swapping lol takes a little bit of time..

I always have a laptop fan running under my computer. It's even got flashing lights with a few patterns to choose from!
My graphics card is Mesa Intel (R) Xe graphics.
I ran sysctl vm swappiness and it completed the command line with = 60.
I should probably run that when the problem occurs I'm guessing. I have a few things to check when it happens now. So that's a good start.

I still have a few minor annoyances I want to fix and then my system will be the way I want it to be. I'll put them in another note. Onward and upward!

60 is normal, that's usually the 'set' parameter for swap - it'll only show that though; you can check the Sys monitor for swap use / percentage. The higher the vm.swappiness value, the more aggressively the swap is used.

You may need to install clinfo to see, but you can check with clinfo in terminal, it should show some stats about your video card - being Intel, I've noticed a lot of OpenCL missing from the drivers; not missing, just non-free support rather. Both newer laptops I have didn't have OpenCL installed by default - just the Mesa-va driver. If you get a blank or rather blank output after running clinfo - may need to install the OpenCL package, not very big. After I got mine installed, all my old WoW games and all came to life, and I was able to use 60fps all-around. Was stuck with 40fps without OpenCL (intel-opencl-icd is the package name).

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.