Fingerprint reader not working, need help finding drivers for '10a5:a900'

Hey Linux community,

I'm a longtime Linux user and I'm loving every minute of it! However, I've hit a roadblock with my fingerprint sensor '10a5:a900'.

I've been trying to find the right drivers for it for the past 6 months with no luck. When I run lsusb, I see the sensor listed as:

Bus 003 Device 002: ID 10a5:a900 FPC FPC Sensor Controller L:0002 FW:

I've tried Googling and troubleshooting on my own, but I haven't been able to find a solution. I've even attempted to enroll my fingerprint using fprintd-enroll, but it throws an error saying "No devices available".

I'm using a Honor MagickBook Pro X14 (2023), and I'm really hoping someone in the Linux community can help me out with this specific sensor. Any assistance would be greatly appreciated!

Sadly, there does not appear to be a driver for this device:

Please remember that most hardware is made for that other OS and relies heavily on reverse engineering to work under Linux kernel. If a fingerprint reader is essential I would recommend a Linux compatible solution from here: