Fingerprint Reader not working

I have a Lenovo Flex 14 that I just installed ZorinOS 16 Core onto. You will have to forgive me in advance, as I am new to Linux and still very much learning. I tried to follow the instructions I found HERE to get my fingerprint reader working, but I've run into a snag.

When I run the instruction meson libfprint libfprint/_build I get some errors and after a little searching, I have no idea what to do. At the end of running that command, it tells me "meson.build:226:12: ERROR: Problem encounter: udev is required for SPI support". Looking a little ways up, I see two more errors: "Run-time dependency cairo found: NO (tried pkgconfig and cmake)" && "Run-time dependency gudev-1.0 found: NO (tried pkgconfig and cmake)". Both of these came after "Found CMake: /usr/bin/cmake (3.16.3)"

Now, I have done a few minor differences from the original tutorials directions. This is because I already tried following his instructions verbatim and it didn't work. So the two things I did differently:

First, in editing the elan.h file, he tells us to add this line - " {.vid = ELAN_VEND_ID, .pid = 0x0c4f, .driver_data = ELAN_ALL_DEV}". I did add this, but I saw his ".pid" line seemed to coincide with his hardware ID from lsusb, so I added another line -" {.vid = ELAN_VEND_ID, .pid = 0x55b4, .driver_data = ELAN_ALL_DEV}" to make this .pid match my hardware ID (I don't know if that is correct reasoning at all, I'm making this up as I go...)

Second - In his command cd libfprint && git checkout v1.90.5 && cd .. I saw that my version number was 1.94.0, so I swapped that in for v1.90.5 (again, don't know if I used good reasoning, just shooting from the hip here)

My fingerprint reader does show up in lsusb as "Bus 003 Device 004: ID 27c6:55b4 Shenzhen Goodix Technology Co.,Ltd. Fingerprint Reader".

Any help would be greatly appreciated.

1 Like

You belong on Linux.

First, check: Settings > Users > Authentication & Login for the built in fingerprint reader. If not present then:

To install fingerprint reader (GUI) first add the repository:

sudo add-apt-repository ppa:fingerprint/fingerprint-gui

Update and install:

sudo apt update && sudo apt upgrade && sudo apt install fingerprint-gui

1 Like

So I tried that and got the error message: "Unable to locate package fingerprint-gui". I looked through the info and did see this line: "Hit:5 Index of /fingerprint/fingerprint-gui/ubuntu focal InRelease"

So I'm not sure what went wrong here.

Edit: Also, in scanning through the information, after I ran the repository add line, there is a line that says the fingerprint GUI is no longer being maintained and not compatible with Ubuntu 20.04 and newer.

1 Like

On further research, it looks like Goodix (the manufacturer of my fingerprint reader) is notoriously bad for releasing linux drivers. Is this likely my issue? Would it show up in lsusb if it didn't have a driver for it? It's looking like my fingerprint reader will be dead for now. . . I sure wish there was a way to get these companies to respond. There are so many requests on their website for linux drivers for their products.

1 Like

I'm confused too. I see that disclaimer, but also see a Focal Package. Welp...

Yes, that is entirely possible.
That's Shenzen for you.

You might try this:
https://www.dell.com/community/XPS/XPS-13-9300-Does-fingerprint-reader-work-on-linux/m-p/7628310/highlight/true#M63982

1 Like

And here is where I show my true Noob status. . . . How do I run that script? . . . :roll_eyes: :roll_eyes:

1 Like

I am sorry, I was in a hurry and posted a link without much help.
You don't need to run a script and looking over the page... It is pretty unclear, too.

If you feel like a "noob" then it looks like Good Training. :slight_smile:
First, open your file manager elevated to Root. Open a terminal with the keyboard shortcut ctrl+alt+t
Then paste or type in the following:
Elevate to Root:

sudo -i

Launch the Nautilus file manager from Root:

nautilus

Navigate to /etc/apt/ and open the file sources.list with a text editor either by double-clicking or with right click and choose which program.
Paste in the entries:

# deb-src http://dell.archive.canonical.com/updates/ focal-dell public

deb http://dell.archive.canonical.com/updates/ focal-oem public
# deb-src http://dell.archive.canonical.com/updates/ focal-oem public

deb http://dell.archive.canonical.com/updates/ focal-somerville public
# deb-src http://dell.archive.canonical.com/updates/ focal-somerville public

deb http://dell.archive.canonical.com/updates/ focal-somerville-melisa public
# deb-src http://dell.archive.canonical.com/updates focal-somerville-melisa public
EOF'

Save and close the file.
Now, open a terminal with the keyboard shortcut ctrl+alt+t again and paste in:
Add the key

sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys F9FDA6BED73CDC22

Update and install the packages

sudo apt update && sudo apt install oem-somerville-melisa-meta libfprint-2-tod1-goodix oem-somerville-meta tlp-config -y

Next to install the application Howdy, add the remote repository

sudo add-apt-repository ppa:boltgolt/howdy -y

Update your sources.list and install with:

sudo apt update && sudo apt install -y howdy

If you get any errors in terminal, please stop and ask to ensure everything goes well.

1 Like

I just want to say that I appreciate all your help. This has been great.

I did get that process to work, but I did not realize until afterward that howdy was for facial recognition. I may use that some day. I'm guessing for now that I'm going to have to live without my fingerprint sensor. I'll have to try to keep an eye out on that over time to see if Goodix finally releases a driver (but I won't be holding my breath. . . )

1 Like

@The_Raven I feel bad for you, don't worry tho. Dell is working with Goodfix for drivers, maybe it will also give support for your fingerprint sensor.

As I understood it (and I could be wrong), Howdy is a facial recognition app but contains the fingerprint drivers as well.

1 Like

Goodfix doesn't even have drivers for Linux tho. I highly doubt Howdy will.

Sorry, been late on the reply. I haven't had a chance to try and reinstall the fingerprint reader (just to see), been too busy fixing the suspension on my MIL's car. However, I just found this forum thread, and things are not looking to positive for the old Goodfix fingerprint reader. . .

2 Likes