Firefox in Firejail - No Internet Access Zorin 15.3

I was last totally fluent in Unix in 1992. I am new to ZorinOS. (ZorinOS Ultimate 15.3, Firefox 80.0.1.
Firejail was pre-installed as was Firefox.
The first time I run Firefox in a sandbox, it works fine. I use a terminal: firejail firefox
I shutdown Zorin and restarted it the next day.
firejail firefox - Firefox appears with all of the same named tabs, but the pages do not load. I tried everything I could find on the internet about this. I verified that the file /etc/firejail/firefox.profile exists. After days of struggle, I uninstalled both firejail and firefox. I reinstalled them both (sudo apt install firejail sudo apt install Firefox).
Success! The browser works in the sandbox again.
I shutdown Zorin and restart. Firefox again has no access to the internet.
Note that Firefox works correctly every time if I do not put it into a sandbox. I’m stymied.
I did a global search and found: firefox.profile, firefox-esr.profile and firefox-nightly.profile. I tried specified each of them. firejail --profile=/etc/firejail/firefox.profile …etc.
Note that the browser works ok all of the time in the sandbox if I specify --noprofile. I have not edited any of the profile files.

jim@Jims-ZorinOS-Desktop:~$ firejail firefox
Reading profile /etc/firejail/firefox.profile
Reading profile /etc/firejail/disable-common.inc
Reading profile /etc/firejail/disable-devel.inc
Reading profile /etc/firejail/disable-programs.inc
Reading profile /etc/firejail/whitelist-common.inc
Reading profile /etc/firejail/whitelist-var-common.inc
Parent pid 5178, child pid 5179
Blacklist violations are logged to syslog
Child process initialized in 66.86 ms

Does this post help from Linux.org?:

As an aside, have you got ufw up and running? also see here:

You may also want to consider ipfire: https://www.ipfire.org/

Other recommendations made to me is to buy a cheap 4Gb RAM 2.4 GHz small Dell desktop pre-configured with pfsense: https://www.pfsense.org/

So to the house it is Router, to box with pfsense then from firewall pc to switch to network connections.

Thanks for your reply. I cannot see anything in the suggested reading that helps. I do have ufw up and running with the default rules. I did try disabling ufw, but it did not help.

I will look into snapd and also consider a gateway computer with pfsense

Thank-you swarfendor437. I looked into purging snapd and then did so. I also looked into shguard and installed. I am now unable to pull out more hair because I’ve already pulled it all out. I still do not have Firefox running in a sandbox. Now, if I purge both firejail and firefox, then reinstall both, I do not get even one use of firefox. It shows all of the tabs with the same names, but the pages are not loaded. I am about to reinstall Zorin from scratch. Although I saw no error messages during the install, maybe something went wrong silently.

I’m pretty certain that the problem is with the firejail profile firefox.profile because the browser works ok if I start it in terminal with no profile: $firejail --noprofile firefox

Ok. I give up. It makes me sad, but I have switched to Google Chrome for my browser. It runs in firejail whereas I cannot get Firefox, my long-term browser, to work properly without specifying --noprofile. Since I do not know what sort of isolation this gives the browser, I do not feel safe using it.

Firefox was my long term browser until recent developments on top of a couple other annoyances- I switched to Vivaldi Browser. Now, I am very happy that I did.

I occasionally use Firefox (but avoid if using to login to a router as it wants to https everything!). Vivaldi is the default browser in the OS I am using currently to write this but using Waterfox. In another browser, now defunct project but very nice am using Cliqz to download the free version of linuxfx 10.6. Oh and Brave Web browser when I feel like it!

Thanks. I’m giving Vivaldi a try, but I’ve already encountered a problem. It reports that it lacks support to play videos. I give a command to update video support. I executed it, but it said:
jim@Jims-ZorinOS-Desktop:~$ sudo /opt/vivaldi/update-ffmpeg
[sudo] password for jim:
Proprietary media codecs (85.0.4183.83) was already present
Vivaldi says to register a bug report, so I will.

The settings on Vivaldi are… extensive… to say the leaset. While it is a great feature that I like, it is confusing to have so many options out there.
Please open the settings and look at the Webpages tab. There may be some settings that effect what you are looking for.

Thanks Aravisian. I have run into several problems now so I am abandoning Vivaldi for the time being. I’ll check back in a few months or a year. I could find nothing on the Webpages section of Settings that helped with the video.

1 Like

Hello,
I am using antiX linux and had the same problem:

firejail firefox - Firefox [opens normally] but the pages do not load.

(I have no such problem with firejail vivaldi.) By trial and error, I found that remarking out “seccomp” from the firejail firefox profile solves the problem, but I have no idea of the security implications :frowning: I assume it’s better than noprofile; I hope someone can educate me.

1 Like

For what it’s worth:

Thanks for your reply. I sometimes now use chromium-browser in firejail, but the browser goes into a strange state at time where the display smears. It becomes unusable. I have resorted to using Firefox without firejail for the time being. It works ok then, except it is losing cookies that I have told it to retain.

Thanks. I will avoid using firejail until I have time to investigate more browsers. I haven’t had good luck on browsers in Zorinos so far: firefox, chrome and vivaldi. Each has different problems. I won’t give up, though. I like working with Zorin. It is bringing back my ancient Unix knowledge. I cannot say that I would recommend it to any of my non-technical Windows and Mac users.

I haven’t looked at it yet but the coordinator of our City Linux User Group sent me a link to a tutorial on how to add TOR to Brave Web browser. :wink:

I have not heard of the Brave browser before. I will check it out. Right now I’m going to post another topic about cookies. Both Firefox and Chrome are forcing me to re-enter the password everytime I switch between 2 email accounts … which I do repeatedly all day long. This is not happening on my Windows machine with Firefox nor with Chrome. I will put more data in the new post. It is very inconvenient.