Firefox Problems with 17.1

Zorin 16 has been my favorite Linux distro for the last year or so.
I installed and tried Zorin 17 today and found 3 problems for me over 16.
The most significant is that I can't use Firefox on 17 to view web pages on the local computer.
I have a page named web.htm on my computer. It is supposed to load a picture, pic.jpg, and it has a link to another local web page, web2.htm. The picture doesn't load and the link doesn't work. It is because when I load web.htm from /home/user, Firefox shows it is loaded from /run/user/1000/doc/???????? and thus it doesn't find either pic.jpg or web2.htm there.
Another problem is that I am used to having a slideshow of backgrounds changing every 3 minutes from a picture directory I choose and a separate directory and set of pictures for each workspace. This doesn't seem possible in Zorin 17. I can use variety as a workaround.
Also I am used to seeing my 4 workspaces on the taskbar and being able to slide windows from one to the other. I haven't figured out how to set this up in Zorin 17 yet.

1 Like

Gday @Woodsman7077 , Welcome to the community.

Could you please tell us a little more.
Are you "TRY"ing or did you "INSTALL" Zorin 17?
If installed is it dual boot?
How did you install Zorin 17(what app did you create the bootable device with?) (eg Rufus/BalenaEtcher/etc)
Can you tell us your machine spec's & brand please.

Also is it Zorin 17.1 or 17 that your wishing to install?

lets start with this first, ty.

I did install Zorin 17 on an old laptop, Dell Latitude E6430, on a 500 Gb hard drive.
It is not dual boot. Zorin 17 is the only OS on that laptop. The bootable device was a Ventoy USB flash drive. The version which I downloaded yesterday is 17.1.

1 Like

On the issue of files not loading via firefox.
Check Firefox's security settings to ensure it allows loading local resources.
Try a different browser to test the links.

I will change the Topic to Issue's with firefox on Zorin 17.1
we or yourself could open another topic of the background issue etc etc.

but lets just concentrate on the firefox issue here.

You may find running the "Software updater" may help.

I tried loading the web page with Opera also with the same result as Firefox.
That's why I thought the problem was with Zorin rather than the browser.
It worked fine with Zorin 16 with both Firefox and Opera.

I will be offline after this reply, but we have others that will help,
Double check the path on these files, if they don't open in two diff browsers then i'd say the path maybe the issue.

If you wish just copy the above issue's you have in your OP, to another topic please.
copy the part for the Background issue.
& another topic for the workspaces issue.
Thank you.

Please be patient other helpers shouldn't be far way.

Have you checked the permissions for the folders/file, Eg: what to do when clicked "Allow executing as "

Zorin OS 17 brought a change in Firefox pacakging. It is now a Flatpak package instead of a .deb package as it always been before.
Being a Flatpak, it lacks access to the Home Directory.

You can try assigning it permissions using Flatseal package or by replacing the Firefox Flatpak with the >deb version.

1 Like

I'll try Flatseal but you should know that I tried opening the web pages from a mounted USB drive rather than from the home directory and had the same problem.

Flatseal worked. In both Opera and Firefox it is necessary to use Flatseal to allow access to user files and that solves the problem of access to local web pages. Thank you.

On you can read how to install the ".deb"-package in Debian/Ubuntu-based distros. Of course only if you don't want to install flatpak or snap and always be up-to-date.