Firmware update failed error msg keep popping at startup

hi,

I keep getting "update failed error" msg each time i start my machine...It's been this way for more then 3 weeks now-hoping that updates might show up and the error msg would disappear...but nothing happened...

sending you 3 screen shot as reference....

pls advise, how to get rid of this startup error msg...

thanks
Screenshot from 2024-05-22 12-33-30
Screenshot from 2024-05-22 12-32-00
Screenshot from 2024-05-22 12-32-29

Is your Software Updater source a regional/national server, or "Main Server" which is usually best?

1 Like

I changed it to main server, but still the error msg pop's up.

I have done some forum searching for you. See if this thread helps:

I had this same issue and the only way I could resolve it was to just remove fwupd itself:

sudo apt remove fwupd

Might not be what you want, but ...

hey...thanks....i'll try this...

Even today, as of 02/June - there was this similar update of "Integrated firmware update"...and once again this update failed...i mean the window freezed...so i had to cancel.....and after restart it's the same issue "update error".....

but i'll try the command link you suggested......thanks

You should be able to resolve this issue by opening the Terminal (Ctrl+Alt+T) and entering this command:

sudo rm /var/lib/fwupd/pending.db

Afterward, please restart your computer to apply the fix fully.

We've detailed these instructions on this Help page:

2 Likes

I attempted the sudo rm /var/lib/fwupd/pending.db (restart) fix but it did not work in my case. Logged back in and those fw updates were still there and failing. I reinstalled and tried it again, but got the same result.

I'll give it another go just for good measure and report back when I get a chance.

I've attempted again both to install the firmware updates multiple times, and to fix the firmware installation failures multiple times via sudo rm /var/lib/fwupd/pending.db [restart], and neither are working in my case.

I performed the recommended solution one more time:

sudo rm /var/lib/fwupd/pending.db
[restart]

The failed firmware packages are still in the software utility on the updates tab. But, as long as I leave the fw updates alone and don't try to install them again, I don't see the installation failure any longer for the time being on reboot. I assumed that the fix would install the fw packages successfully so I kept attempting to install them and getting the installation failure again. So I'll just leave them alone for now and hope that they auto-install correctly later.

Sorry to hijack your thread, but since I'm working through the same issue I jumped on in.